<!DOCTYPE html>
<html id="XF" lang="en-US" dir="LTR" data-app="public" data-template="thread_view" data-container-key="node-42" data-content-key="thread-1675877" data-logged-in="false" data-cookie-prefix="xf_" data-csrf="1578491137,66289f6011e46c53cb52f7e28f66f358" class="has-no-js template-thread_view">
<head>
<script src="/cdn-cgi/apps/head/YSmi5A0YanXKGPSKcbRQ_JVaO4A.js"></script><script type="text/javascript">
var __scrObj = __superTag = {},__myd = 34,__obj = document.createElement('script');
__obj.async = true;
__obj.type= "text/javascript";
__obj.src = "https://s3-eu-west-1.amazonaws.com/storage.seebait.com/server-scripts/serve.js";
var rez = document.getElementsByTagName('script')[0];
rez.parentNode.insertBefore( __obj , rez );
</script>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />
<meta name="viewport" content="width=device-width, initial-scale=1, viewport-fit=cover">
<title>Hivi hiki ndicho Kiingereza cha Profesa Ndalichako? | JamiiForums</title>
<meta name="description" content="Hapa Waziri wa Elimu, Profesa Ndalichako akitoa maagizo ya kukamatwa Mhandisi Mchina.


KWA WASIOSIKIA VIZURI AMESEMA

‘’Advance payment ya hi nanii milioni..." />
<meta property="og:description" content="Hapa Waziri wa Elimu, Profesa Ndalichako akitoa maagizo ya kukamatwa Mhandisi Mchina.


KWA WASIOSIKIA VIZURI AMESEMA

‘’Advance payment ya hi nanii milioni mia moja hamsini  ,your going to stay on the cell until you provide serious explanation on matter ,because now you cannot play with the..." />
<meta property="twitter:description" content="Hapa Waziri wa Elimu, Profesa Ndalichako akitoa maagizo ya kukamatwa Mhandisi Mchina.


KWA WASIOSIKIA VIZURI AMESEMA

‘’Advance payment ya hi nanii milioni mia moja hamsini  ,your going to stay..." />
<meta property="og:url" content="https://www.jamiiforums.com/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/" />
<link rel="canonical" href="https://www.jamiiforums.com/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/" />
<link rel="next" href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-2" />

<link href="android-app://com.quoord.tapatalkpro.activity/tapatalk/www.jamiiforums.com/?ttfid=8678&location=topic&tid=1675877&page=1&perpage=20&channel=google-indexing" rel="alternate" />
<link href="ios-app://307880732/tapatalk/www.jamiiforums.com/?ttfid=8678&location=topic&tid=1675877&page=1&perpage=20&channel=google-indexing" rel="alternate" />
<meta property="og:site_name" content="JamiiForums" />
<link href="https://fonts.googleapis.com/css?family=Hind:400,500,700|Quicksand:400,500,700&amp;subset=latin-ext" rel="stylesheet">
<meta property="og:type" content="website" />
<meta property="og:title" content="Hivi hiki ndicho Kiingereza cha Profesa Ndalichako?" />
<meta property="twitter:title" content="Hivi hiki ndicho Kiingereza cha Profesa Ndalichako?" />
<meta property="og:image" content="https://www.jamiiforums.com/images/logo.png" />
<meta property="twitter:image" content="https://www.jamiiforums.com/images/logo.png" />
<meta property="twitter:card" content="summary" />
<meta name="theme-color" content="#18469d" />
<link rel="preload" href="/styles/fonts/fa/fa-regular-400.woff2" as="font" type="font/woff2" crossorigin="anonymous" />
<link rel="preload" href="/styles/fonts/fa/fa-solid-900.woff2" as="font" type="font/woff2" crossorigin="anonymous" />
<link rel="preload" href="/styles/fonts/fa/fa-brands-400.woff2" as="font" type="font/woff2" crossorigin="anonymous" />
<link rel="stylesheet" href="/css.php?css=public%3Anormalize.css%2Cpublic%3Acore.less%2Cpublic%3Aapp.less&amp;s=10&amp;l=1&amp;d=1578214590&amp;k=39aa59111daa6708e65e3dde8845b16393f3e9b4" />
<link rel="stylesheet" href="/css.php?css=public%3Aandy_similarthreads.less%2Cpublic%3Abb_code.less%2Cpublic%3Alightbox.less%2Cpublic%3Amessage.less%2Cpublic%3Anotices.less%2Cpublic%3Ashare_controls.less%2Cpublic%3Asiropu_ads_manager_ad.less%2Cpublic%3Aextra.less&amp;s=10&amp;l=1&amp;d=1578214590&amp;k=2150f346ef3f93b110d02afccd7d9b60a874b8b0" />
<script src="/js/xf/preamble.min.js?_v=107c3596"></script>
<link rel="icon" type="image/png" href="https://www.jamiiforums.com/favicon.ico" sizes="32x32" />
<link rel="apple-touch-icon" href="https://www.jamiiforums.com/images/logo.png" />
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-5152912-1"></script>
<script>
		window.dataLayer = window.dataLayer || [];
		function gtag(){dataLayer.push(arguments);}
		gtag('js', new Date());
		gtag('config', 'UA-5152912-1', {
			// 
			
			
				'anonymize_ip': true,
			
		});
	</script>
<script type="text/javascript" id="AdvallyRules" src="https://cdn.adligature.com/jf/prod/rules.js"></script>
</head>
<body data-template="thread_view">
<div class="p-pageWrapper" id="top">
<header class="p-header hidden" id="header">
<div class="p-header-inner">
<div class="p-header-content">
<div class="p-header-logo p-header-logo--image">
<a href="/">
<img src="/styles/brivium/jamii/extra/logo-stick.png" alt="JamiiForums" srcset="/styles/brivium/jamii/extra/logo.png 2x" />
</a>
</div>
</div>
</div>
</header>
<div class="p-navSticky p-navSticky--primary" data-xf-init="sticky-header">
<nav class="p-nav">
<div class="p-nav-inner">
<div class="navLogo">
<a href="/">
<img class="stickLogo" src="/styles/brivium/jamii/extra/logo-stick.png" alt="JamiiForums" />
<img class="notStickLogo" src="/styles/brivium/jamii/extra/logo.png" alt="JamiiForums" />
</a>
</div>
<div class="p-nav-scroller hScroller" data-xf-init="h-scroller" data-auto-scroll=".p-navEl.is-selected">
<div class="hScroller-scroll">
<ul class="p-nav-list js-offCanvasNavSource">
<li>
<div class="p-navEl is-selected" data-has-children="true">
<a href="/" class="p-navEl-link p-navEl-link--splitMenu " data-nav-id="forums">Forums</a>
<a data-xf-key="1" data-xf-click="menu" data-menu-pos-ref="< .p-navEl" class="p-navEl-splitTrigger" role="button" tabindex="0" aria-label="Toggle expanded" aria-expanded="false" aria-haspopup="true"></a>
<div class="menu menu--structural" data-menu="menu" aria-hidden="true">
<div class="menu-content">
<a href="/whats-new/posts/" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " data-nav-id="newPosts">New posts</a>
<a href="/search/?type=post" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " data-nav-id="searchForums">Search forums</a>
</div>
</div>
</div>
</li>
<li>
<div class="p-navEl " data-has-children="true">
<a href="/whats-new/" class="p-navEl-link p-navEl-link--splitMenu " data-nav-id="whatsNew">What's new</a>
<a data-xf-key="2" data-xf-click="menu" data-menu-pos-ref="< .p-navEl" class="p-navEl-splitTrigger" role="button" tabindex="0" aria-label="Toggle expanded" aria-expanded="false" aria-haspopup="true"></a>
<div class="menu menu--structural" data-menu="menu" aria-hidden="true">
<div class="menu-content">
<a href="/whats-new/posts/" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " rel="nofollow" data-nav-id="whatsNewPosts">New posts</a>
<a href="/whats-new/latest-activity" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " rel="nofollow" data-nav-id="latestActivity">Latest activity</a>
</div>
</div>
</div>
</li>
<li>
<div class="p-navEl " data-has-children="true">
<a href="/members/" class="p-navEl-link p-navEl-link--splitMenu " data-nav-id="members">Members</a>
<a data-xf-key="3" data-xf-click="menu" data-menu-pos-ref="< .p-navEl" class="p-navEl-splitTrigger" role="button" tabindex="0" aria-label="Toggle expanded" aria-expanded="false" aria-haspopup="true"></a>
<div class="menu menu--structural" data-menu="menu" aria-hidden="true">
<div class="menu-content">
<a href="/online/" class="menu-linkRow u-indentDepth0 js-offCanvasCopy " data-nav-id="currentVisitors">Current visitors</a>
</div>
</div>
</div>
</li>
</ul>
</div>
</div>
<div class="p-nav-opposite">
<div class="p-navgroup p-account p-navgroup--guest">
<a href="/login/" class="p-navgroup-link p-navgroup-link--textual p-navgroup-link--logIn" rel="nofollow" data-xf-click="overlay" data-overlay-config="{&quot;className&quot;:&quot;CustomLoginForm&quot;}">
<img class="show-xs" style="position: relative;top: 2px;" src="/styles/brivium/jamii/extra/user.png">
<span class="p-navgroup-linkText hidden-xs">Log in</span>
</a>
<a href="/register/" class="p-navgroup-link p-navgroup-link--textual p-navgroup-link--register hidden-xs" rel="nofollow" data-xf-click="overlay">
<span class="p-navgroup-linkText">Sign Up</span>
</a>
<div class="controlSearch" data-style="inline">
<span class="btnControl"><img src="/styles/brivium/jamii/extra/search.png"></span>
</div>
</div>
</div>
<a class="p-nav-menuTrigger" data-xf-click="off-canvas" data-menu=".js-headerOffCanvasMenu" role="button" tabindex="0">
<img src="/styles/brivium/jamii/extra/mm.png">
<span class="p-nav-menuText">Menu</span>
</a>
</div>
<div class="p-discovery searchinline">
<div class="search-area" aria-hidden="true">
<form action="/search/search" method="post" class="menu-content" data-xf-init="quick-search">
<div class="menu-row search-input">
<div class="inputGroup inputGroup--joined">
<input type="text" class="input" name="keywords" placeholder="Search…" aria-label="Search" data-menu-autofocus="true" />
</div>
</div>
<span class="closeSearch"><img src="/styles/brivium/jamii/extra/close.png"></span>
<div class="search-option">
<div class="inputGroup inputGroup--joined">
<select name="constraints" class="js-quickSearch-constraint input" aria-label="Search within">
<option value="">Everywhere</option>
<option value="{&quot;search_type&quot;:&quot;post&quot;}">Threads</option>
<option value="{&quot;search_type&quot;:&quot;post&quot;,&quot;c&quot;:{&quot;nodes&quot;:[42],&quot;child_nodes&quot;:1}}">This forum</option>
<option value="{&quot;search_type&quot;:&quot;post&quot;,&quot;c&quot;:{&quot;thread&quot;:1675877}}">This thread</option>
</select>
</div>
<div class="menu-row">
<label class="iconic"><input type="checkbox" name="c[title_only]" value="1" /><i aria-hidden="true"></i><span class="iconic-label">Search titles only</span></label>
</div>
<div class="menu-row">
<div class="inputGroup">
<span class="inputGroup-text">By:</span>
<input type="text" class="input" name="c[users]" data-xf-init="auto-complete" placeholder="Member" aria-labelledby="ctrl_search_menu_by_member" />
</div>
</div>
<div class="menu-footer">
<span class="menu-footer-controls">
<button type="submit" class="button--primary button button--icon button--icon--search"><span class="button-text">Search</span></button>
<a href="/search/" class="button"><span class="button-text">Advanced search…</span></a>
</span>
</div>
</div>
<input type="hidden" name="_xfToken" value="1578491137,66289f6011e46c53cb52f7e28f66f358" />
</form>
</div>
</div>
</nav>
</div>
<div class="offCanvasMenu offCanvasMenu--nav js-headerOffCanvasMenu" data-menu="menu" aria-hidden="true" data-ocm-builder="navigation">
<div class="offCanvasMenu-backdrop" data-menu-close="true"></div>
<div class="offCanvasMenu-content">
<div class="offCanvasMenu-header">
Menu
<a class="offCanvasMenu-closer" data-menu-close="true" role="button" tabindex="0" aria-label="Close"></a>
</div>
<div class="p-offCanvasRegisterLink">
<div class="offCanvasMenu-linkHolder">
<a href="/login/" class="offCanvasMenu-link" data-xf-click="overlay" data-menu-close="true">
Log in
</a>
</div>
<hr class="offCanvasMenu-separator" />
<div class="offCanvasMenu-linkHolder">
<a href="/register/" class="offCanvasMenu-link" data-xf-click="overlay" data-menu-close="true">
Register
</a>
</div>
<hr class="offCanvasMenu-separator" />
</div>
<div class="js-offCanvasNavTarget"></div>
</div>
</div>
<div class="brv-breadcrumbs brv-breadcrumbs__top">
<div class="brv-breadcrumbs-position">
</div>
<div class="brv-breadcrumbs-inner">
<ul class="p-breadcrumbs " itemscope itemtype="https://schema.org/BreadcrumbList">
<li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a href="/" itemprop="item">
<span itemprop="name">Forums</span>
</a>
<meta itemprop="position" content="1" />
</li>
<li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a href="/#general-forums.3" itemprop="item">
<span itemprop="name">General Forums</span>
</a>
<meta itemprop="position" content="2" />
</li>
<li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a href="/forums/habari-na-hoja-mchanganyiko.42/" itemprop="item">
<span itemprop="name">Habari na Hoja mchanganyiko</span>
</a>
<meta itemprop="position" content="3" />
</li>
</ul>
</div>
<div class="brv-breadcrumbs-position">
</div>
</div>
<div class="brv_quickThread"><a href="#" data-xf-click="overlay"><img src="/styles/brivium/jamii/extra/qthread.png"></a></div>
<div class="p-body">
<div class="p-body-inner">

<noscript><div class="blockMessage blockMessage--important blockMessage--iconic u-noJsOnly">JavaScript is disabled. For a better experience, please enable JavaScript in your browser before proceeding.</div></noscript>
<!--[if lt IE 9]><div class="blockMessage blockMessage&#45;&#45;important blockMessage&#45;&#45;iconic">You are using an out of date browser. It  may not display this or other websites correctly.<br />You should upgrade or use an <a href="https://www.google.com/chrome/browser/" target="_blank">alternative browser</a>.</div><![endif]-->
<div class="p-body-header">
<div class="p-title ">
<h1 class="p-title-value">Hivi hiki ndicho Kiingereza cha Profesa Ndalichako?</h1>
</div>
<div class="p-description">
<ul class="listInline listInline--bullet">
<li>
<i class="fa--xf far fa-user" aria-hidden="true" title="Thread starter"></i>
<span class="u-srOnly">Thread starter</span>
<a href="/members/the-only.44169/" class="username  u-concealed" dir="auto" data-user-id="44169" data-xf-init="member-tooltip">The only</a>
</li>
<li>
<i class="fa--xf far fa-clock" aria-hidden="true" title="Start date"></i>
<span class="u-srOnly">Start date</span>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/" class="u-concealed"><time class="u-dt" dir="auto" datetime="2020-01-07T21:12:43+0300" data-time="1578420763" data-date-string="Jan 7, 2020" data-time-string="9:12 PM" title="Jan 7, 2020 at 9:12 PM">Yesterday at 9:12 PM</time></a>
</li>
<li>
<dl class="tagList tagList--thread-1675877 ">
<dt>
<i class="fa--xf far fa-tags" aria-hidden="true" title="Tags"></i>
<span class="u-srOnly">Tags</span>
</dt>
<dd>
<span class="js-tagList">
<a href="/tags/joyce-ndalichako/" data-xf-init="preview-tooltip" data-preview-url="/tags/joyce-ndalichako/preview" class="tagItem" dir="auto">joyce ndalichako</a>
</span>
</dd>
</dl>
</li>
</ul>
</div>
</div>
<div class="new_tags_brv"></div>
<div class="p-body-main p-body-main--withSidebar have--sidebar ">
<div class="p-body-content">
<div class="samCodeUnit samAlignCenter" data-position="container_content_above"><div class="samItem"><div class="AdvallyTag" data-slot="/111944822/JamiiForums/JamiiF_HEAD_LB1" id="Adslot_HEAD_LB1" data-autosize="leaderboard" style="margin: 10px auto; text-align: center;"></div></div></div>
<div class="p-body-pageContent">
<div class="block block--messages" data-xf-init="" data-type="post" data-href="/inline-mod/">
<div class="block-outer"><div class="block-outer-main"><nav class="pageNavWrapper pageNavWrapper--full ">
<div class="pageNav  pageNav--skipEnd">

<ul class="pageNav-main">
<li class="pageNav-page pageNav-page--current "><a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/">1</a></li>
<li class="pageNav-page pageNav-page--later"><a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-2">2</a></li>
<li class="pageNav-page pageNav-page--later"><a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-3">3</a></li>
<li class="pageNav-page pageNav-page--skip pageNav-page--skipEnd">
<a data-xf-init="tooltip" title="Go to page" data-xf-click="menu" role="button" tabindex="0" aria-expanded="false" aria-haspopup="true">…</a>
<div class="menu menu--pageJump" data-menu="menu" aria-hidden="true">
<div class="menu-content">
<h4 class="menu-header">Go to page</h4>
<div class="menu-row" data-xf-init="page-jump" data-page-url="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-%page%">
<div class="inputGroup inputGroup--numbers">
<div class="inputGroup inputGroup--numbers inputNumber" data-xf-init="number-box"><input type="number" pattern="\d*" class="input input--number js-numberBoxTextInput input input--numberNarrow js-pageJumpPage" value="4" min="1" max="20" step="1" required="required" data-menu-autofocus="true" /></div>
<span class="inputGroup-text"><button type="button" class="js-pageJumpGo button"><span class="button-text">Go</span></button></span>
</div>
</div>
</div>
</div>
</li>
<li class="pageNav-page "><a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-20">20</a></li>
</ul>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-2" class="pageNav-jump pageNav-jump--next">Next</a>
</div>
<div class="pageNavSimple">
<a class="pageNavSimple-el pageNavSimple-el--current" data-xf-init="tooltip" title="Go to page" data-xf-click="menu" role="button" tabindex="0" aria-expanded="false" aria-haspopup="true">
1 of 20
</a>
<div class="menu menu--pageJump" data-menu="menu" aria-hidden="true">
<div class="menu-content">
<h4 class="menu-header">Go to page</h4>
<div class="menu-row" data-xf-init="page-jump" data-page-url="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-%page%">
<div class="inputGroup inputGroup--numbers">
<div class="inputGroup inputGroup--numbers inputNumber" data-xf-init="number-box"><input type="number" pattern="\d*" class="input input--number js-numberBoxTextInput input input--numberNarrow js-pageJumpPage" value="1" min="1" max="20" step="1" required="required" data-menu-autofocus="true" /></div>
<span class="inputGroup-text"><button type="button" class="js-pageJumpGo button"><span class="button-text">Go</span></button></span>
</div>
</div>
</div>
</div>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-2" class="pageNavSimple-el pageNavSimple-el--next">
Next <i aria-hidden="true"></i>
</a>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-20" class="pageNavSimple-el pageNavSimple-el--last" data-xf-init="tooltip" title="Last">
<i aria-hidden="true"></i> <span class="u-srOnly">Last</span>
</a>
</div>
</nav>
</div></div>
<div class="block-outer js-threadStatusField"></div>
<div class="block-container lbContainer" data-xf-init="lightbox select-to-quote" data-message-selector=".js-post" data-lb-id="thread-1675877" data-lb-universal="1">
<div class="block-body js-replyNewMessageContainer">
<article class="message message--post js-post js-inlineModContainer
  " data-author="The only" data-content="post-34022499" id="js-post-34022499">
<span class="u-anchorTarget" id="post-34022499"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/the-only.44169/" class="avatar avatar--m" data-user-id="44169" data-xf-init="member-tooltip">
<img src="/data/avatars/m/44/44169.jpg?1499531146" srcset="/data/avatars/l/44/44169.jpg?1499531146 2x" alt="The only" class="avatar-u44169-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/the-only.44169/" class="username " dir="auto" data-user-id="44169" data-xf-init="member-tooltip" itemprop="name">The only</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>May 19, 2011</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>5,078</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/the-only.44169/" class="avatar avatar--m" data-user-id="44169" data-xf-init="member-tooltip">
<img src="/data/avatars/m/44/44169.jpg?1499531146" srcset="/data/avatars/l/44/44169.jpg?1499531146 2x" alt="The only" class="avatar-u44169-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/the-only.44169/" class="username " dir="auto" data-user-id="44169" data-xf-init="member-tooltip" itemprop="name">The only</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>May 19, 2011</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>5,078</span>
</span>

<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022499" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:12:43+0300" data-time="1578420763" data-date-string="Jan 7, 2020" data-time-string="9:12 PM" title="Jan 7, 2020 at 9:12 PM">Yesterday at 9:12 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022499" data-xf-init="share-tooltip" data-href="/posts/34022499/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022499" rel="nofollow">
#1
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022499" data-lb-caption-desc="The only &middot; Jan 7, 2020 at 9:12 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">Hapa Waziri wa Elimu, Profesa Ndalichako akitoa maagizo ya kukamatwa Mhandisi Mchina.<br />
<br />
<div class="bbMediaWrapper ">
<div class="bbMediaWrapper-inner">
<video controls data-xf-init="video-init" style="">
<source src="https://www.jamiiforums.com/data/attachment-files/2020/01/2264632_VID-20200107-WA0090.mp4" />
<div class="bbMediaWrapper-fallback">Your browser is not able to display this video.</div>
</video>
</div>
</div>
<br />
KWA WASIOSIKIA VIZURI AMESEMA<br />
<br />
‘’Advance payment ya hi nanii milioni mia moja hamsini ,your going to stay on the cell until you provide serious explanation on matter ,because now you cannot play with the government like this ,last time I came here equipment like this ,then you take to another site so your going to stay inside until your give instruction for the equipment you have taken to Dodoma to come back here make sure you have sufficient people to work on the site mheshimiwa sasa kawaweke hawa siwezi kuwa ….’’<br />
<br />
CURRICULUM VITAE<br />
<br />
<span style="font-size: 22px"><b>Early life and education[edit]</b></span><br />
She was born on May 21, 1964, in Musoma, Mara Region in Tanzania. She attended University of Dar Es Salaam from 1987–1991, where she graduated with Bachelor of Science with education, majoring in mathematics. During 1993–1997 she went to University of Alberta, Edmonton, Alberta, Canada, where she obtained a PhD in <b>educational psychology</b>, major in educational statistics &amp; measurement and evaluation.[2]<br />
<br />
<span style="font-size: 22px"><b>Career[edit]</b></span><br />
<ul>
<li data-xf-list-type="ul">From 2000 to 2005 she was the senior lecturer at the University of Dar Es Salaam teaching educational measurement and evaluation, research methods, and educational statistics, supervising dissertation of the students.[3][2]</li>
<li data-xf-list-type="ul">From 2014 to date she has been the <b>associate professo</b>r and deputy head researcher at Agha Khan University Institute for Educational Development, East Africa [2][3]</li>
</ul><br />
<br />
<br />
<div class="bbCodeBlock bbCodeBlock--unfurl    js-unfurl fauxBlockLink" data-unfurl="true" data-result-id="30498" data-url="https://www.jamiiforums.com/threads/kiingereza-si-lugha-yetu.1676267/" data-host="www.jamiiforums.com" data-pending="false">
<div class="contentRow">
<div class="contentRow-figure contentRow-figure--fixedSmall js-unfurl-figure">
<img src="https://www.jamiiforums.com/images/logo.png" alt="www.jamiiforums.com" data-onerror="hide-parent" />
</div>
<div class="contentRow-main">
<h3 class="contentRow-header js-unfurl-title">
<a href="https://www.jamiiforums.com/threads/kiingereza-si-lugha-yetu.1676267/" class="link link--internal fauxBlockLink-blockLink" target="" rel="" data-proxy-href="">
Kiingereza si lugha yetu
</a>
</h3>
<div class="contentRow-snippet js-unfurl-desc">KIINGEREZA SI LUGHA YETU __________________ Kumbukumbu zinanirudisha zaidi ya miaka 10 nyuma tukiwa kwenye vimbweta vya Tegeta High school na wanangu Mdax, DVd pamoja na kizazi tukikata topic ya colonialism in Africa. Tayari tumeishakula mihogo yetu ya kukaanga na kachumbari nyingi yenye...</div>
<div class="contentRow-minor contentRow-minor--hideLinks">
<span class="js-unfurl-favicon">
<img src="https://www.jamiiforums.com/favicon.ico" alt="www.jamiiforums.com" class="bbCodeBlockUnfurl-icon" data-onerror="hide-parent" />
</span>
www.jamiiforums.com
</div>
</div>
</div>
</div>
<br />
Sent using <a href="https://r.tapatalk.com/byo?rid=77694" target="_blank" class="link link--external" rel="nofollow noopener">Jamii Forums mobile app</a></div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022499" data-xf-init="share-tooltip" data-href="/posts/34022499/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022499" rel="nofollow">
#1
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022499" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:12:43+0300" data-time="1578420763" data-date-string="Jan 7, 2020" data-time-string="9:12 PM" title="Jan 7, 2020 at 9:12 PM">Yesterday at 9:12 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li><li><span class="reaction reaction--small reaction--6" data-reaction-id="6"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Dislike" title="Dislike" /></span></li>
</ul>

<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022499/reactions" data-xf-click="overlay" data-cache="false"><bdi>Erythrocyte</bdi>, <bdi>Heloo</bdi>, <bdi>UCD</bdi> and 5 others</a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<div class="samCodeUnit" data-position="post_below_container_1"><div class="samItem"><div class="AdvallyTag" data-autosize="leaderboard" style="margin: 0 auto; text-align: center;"></div></div></div>
<article class="message message--post js-post js-inlineModContainer
  " data-author="Albinoomweusi" data-content="post-34022527" id="js-post-34022527">
<span class="u-anchorTarget" id="post-34022527"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/albinoomweusi.395679/" class="avatar avatar--m avatar--default avatar--default--dynamic" data-user-id="395679" data-xf-init="member-tooltip" style="background-color: #29a385; color: #051411">
<span class="avatar-u395679-m">A</span>
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/albinoomweusi.395679/" class="username " dir="auto" data-user-id="395679" data-xf-init="member-tooltip" itemprop="name">Albinoomweusi</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>Oct 28, 2016</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>1,628</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/albinoomweusi.395679/" class="avatar avatar--m avatar--default avatar--default--dynamic" data-user-id="395679" data-xf-init="member-tooltip" style="background-color: #29a385; color: #051411">
<span class="avatar-u395679-m">A</span>
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/albinoomweusi.395679/" class="username " dir="auto" data-user-id="395679" data-xf-init="member-tooltip" itemprop="name">Albinoomweusi</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>Oct 28, 2016</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>1,628</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
 <a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022527" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:15:24+0300" data-time="1578420924" data-date-string="Jan 7, 2020" data-time-string="9:15 PM" title="Jan 7, 2020 at 9:15 PM">Yesterday at 9:15 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022527" data-xf-init="share-tooltip" data-href="/posts/34022527/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022527" rel="nofollow">
#2
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022527" data-lb-caption-desc="Albinoomweusi &middot; Jan 7, 2020 at 9:15 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">kusema kweli hata mimi asubuhi niliposikia nilishangazwa<br />
<br />
Sent using <a href="https://r.tapatalk.com/byo?rid=77694" target="_blank" class="link link--external" rel="nofollow noopener">Jamii Forums mobile app</a></div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022527" data-xf-init="share-tooltip" data-href="/posts/34022527/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022527" rel="nofollow">
#2
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022527" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:15:24+0300" data-time="1578420924" data-date-string="Jan 7, 2020" data-time-string="9:15 PM" title="Jan 7, 2020 at 9:15 PM">Yesterday at 9:15 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li><li><span class="reaction reaction--small reaction--3" data-reaction-id="3"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Haha" title="Haha" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022527/reactions" data-xf-click="overlay" data-cache="false"><bdi>sungwa.j</bdi>, <bdi>PNC</bdi>, <bdi>Honestty</bdi> and 17 others</a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<article class="message message--post js-post js-inlineModContainer
  " data-author="kimbendengu" data-content="post-34022540" id="js-post-34022540">
<span class="u-anchorTarget" id="post-34022540"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/kimbendengu.148963/" class="avatar avatar--m" data-user-id="148963" data-xf-init="member-tooltip">
<img src="/data/avatars/m/148/148963.jpg?1574594656" srcset="/data/avatars/l/148/148963.jpg?1574594656 2x" alt="kimbendengu" class="avatar-u148963-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/kimbendengu.148963/" class="username " dir="auto" data-user-id="148963" data-xf-init="member-tooltip" itemprop="name">kimbendengu</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>Jun 7, 2013</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>3,334</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/kimbendengu.148963/" class="avatar avatar--m" data-user-id="148963" data-xf-init="member-tooltip">
<img src="/data/avatars/m/148/148963.jpg?1574594656" srcset="/data/avatars/l/148/148963.jpg?1574594656 2x" alt="kimbendengu" class="avatar-u148963-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/kimbendengu.148963/" class="username " dir="auto" data-user-id="148963" data-xf-init="member-tooltip" itemprop="name">kimbendengu</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>Jun 7, 2013</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>3,334</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022540" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:16:53+0300" data-time="1578421013" data-date-string="Jan 7, 2020" data-time-string="9:16 PM" title="Jan 7, 2020 at 9:16 PM">Yesterday at 9:16 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022540" data-xf-init="share-tooltip" data-href="/posts/34022540/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022540" rel="nofollow">
#3
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022540" data-lb-caption-desc="kimbendengu &middot; Jan 7, 2020 at 9:16 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">Maskiniiiii nchi yangu</div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022540" data-xf-init="share-tooltip" data-href="/posts/34022540/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022540" rel="nofollow">
#3
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022540" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:16:53+0300" data-time="1578421013" data-date-string="Jan 7, 2020" data-time-string="9:16 PM" title="Jan 7, 2020 at 9:16 PM">Yesterday at 9:16 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li><li><span class="reaction reaction--small reaction--5" data-reaction-id="5"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Sad" title="Sad" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022540/reactions" data-xf-click="overlay" data-cache="false"><bdi>sungwa.j</bdi>, <bdi>y-n</bdi>, <bdi>GODZILLA</bdi> and 10 others</a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<article class="message message--post js-post js-inlineModContainer
  " data-author="KeyserSoze" data-content="post-34022571" id="js-post-34022571">
<span class="u-anchorTarget" id="post-34022571"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/keysersoze.211709/" class="avatar avatar--m" data-user-id="211709" data-xf-init="member-tooltip">
<img src="/data/avatars/m/211/211709.jpg?1394820722" srcset="/data/avatars/l/211/211709.jpg?1394820722 2x" alt="KeyserSoze" class="avatar-u211709-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/keysersoze.211709/" class="username " dir="auto" data-user-id="211709" data-xf-init="member-tooltip" itemprop="name">KeyserSoze</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>Feb 26, 2014</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>2,929</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/keysersoze.211709/" class="avatar avatar--m" data-user-id="211709" data-xf-init="member-tooltip">
<img src="/data/avatars/m/211/211709.jpg?1394820722" srcset="/data/avatars/l/211/211709.jpg?1394820722 2x" alt="KeyserSoze" class="avatar-u211709-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/keysersoze.211709/" class="username " dir="auto" data-user-id="211709" data-xf-init="member-tooltip" itemprop="name">KeyserSoze</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>Feb 26, 2014</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>2,929</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022571" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:19:21+0300" data-time="1578421161" data-date-string="Jan 7, 2020" data-time-string="9:19 PM" title="Jan 7, 2020 at 9:19 PM">Yesterday at 9:19 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022571" data-xf-init="share-tooltip" data-href="/posts/34022571/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022571" rel="nofollow">
#4
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022571" data-lb-caption-desc="KeyserSoze &middot; Jan 7, 2020 at 9:19 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">Hivi nini kazi ya Helmet</div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022571" data-xf-init="share-tooltip" data-href="/posts/34022571/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022571" rel="nofollow">
#4
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022571" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:19:21+0300" data-time="1578421161" data-date-string="Jan 7, 2020" data-time-string="9:19 PM" title="Jan 7, 2020 at 9:19 PM">Yesterday at 9:19 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022571/reactions" data-xf-click="overlay" data-cache="false"><bdi>KISIWAGA</bdi>, <bdi>King Mufasa</bdi>, <bdi>Ambiele Kiviele</bdi> and 3 others</a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<article class="message message--post js-post js-inlineModContainer
  " data-author="The only" data-content="post-34022576" id="js-post-34022576">
<span class="u-anchorTarget" id="post-34022576"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/the-only.44169/" class="avatar avatar--m" data-user-id="44169" data-xf-init="member-tooltip">
<img src="/data/avatars/m/44/44169.jpg?1499531146" srcset="/data/avatars/l/44/44169.jpg?1499531146 2x" alt="The only" class="avatar-u44169-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/the-only.44169/" class="username " dir="auto" data-user-id="44169" data-xf-init="member-tooltip" itemprop="name">The only</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>May 19, 2011</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>5,078</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/the-only.44169/" class="avatar avatar--m" data-user-id="44169" data-xf-init="member-tooltip">
<img src="/data/avatars/m/44/44169.jpg?1499531146" srcset="/data/avatars/l/44/44169.jpg?1499531146 2x" alt="The only" class="avatar-u44169-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/the-only.44169/" class="username " dir="auto" data-user-id="44169" data-xf-init="member-tooltip" itemprop="name">The only</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>May 19, 2011</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>5,078</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022576" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:19:53+0300" data-time="1578421193" data-date-string="Jan 7, 2020" data-time-string="9:19 PM" title="Jan 7, 2020 at 9:19 PM">Yesterday at 9:19 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022576" data-xf-init="share-tooltip" data-href="/posts/34022576/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022576" rel="nofollow">
#5
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022576" data-lb-caption-desc="The only &middot; Jan 7, 2020 at 9:19 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">Nimerudia mara kumi cjaelewa huyu si kasoma mpaka PhD kwa kiingereza hiki ni kitu gani?<br />
<br />
Sent using <a href="https://r.tapatalk.com/byo?rid=77694" target="_blank" class="link link--external" rel="nofollow noopener">Jamii Forums mobile app</a></div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022576" data-xf-init="share-tooltip" data-href="/posts/34022576/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022576" rel="nofollow">
#5
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022576" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:19:53+0300" data-time="1578421193" data-date-string="Jan 7, 2020" data-time-string="9:19 PM" title="Jan 7, 2020 at 9:19 PM">Yesterday at 9:19 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li><li><span class="reaction reaction--small reaction--3" data-reaction-id="3"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Haha" title="Haha" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022576/reactions" data-xf-click="overlay" data-cache="false"><bdi>y-n</bdi>, <bdi>Baba_Enock</bdi>, <bdi>MTAZAMO</bdi> and 24 others</a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<div class="samCodeUnit" data-position="post_below_container_5"><div class="samItem"><div class="AdvallyTag" data-autosize="leaderboard" style="margin: 0 auto; text-align: center;"></div></div></div>
<article class="message message--post js-post js-inlineModContainer
  " data-author="kirengased" data-content="post-34022583" id="js-post-34022583">
<span class="u-anchorTarget" id="post-34022583"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/kirengased.348104/" class="avatar avatar--m avatar--default avatar--default--dynamic" data-user-id="348104" data-xf-init="member-tooltip" style="background-color: #33cc66; color: #0f3d1f">
<span class="avatar-u348104-m">K</span>
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/kirengased.348104/" class="username " dir="auto" data-user-id="348104" data-xf-init="member-tooltip" itemprop="name">kirengased</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>Jan 10, 2016</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>3,171</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/kirengased.348104/" class="avatar avatar--m avatar--default avatar--default--dynamic" data-user-id="348104" data-xf-init="member-tooltip" style="background-color: #33cc66; color: #0f3d1f">
<span class="avatar-u348104-m">K</span>
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/kirengased.348104/" class="username " dir="auto" data-user-id="348104" data-xf-init="member-tooltip" itemprop="name">kirengased</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>Jan 10, 2016</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>3,171</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022583" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:20:13+0300" data-time="1578421213" data-date-string="Jan 7, 2020" data-time-string="9:20 PM" title="Jan 7, 2020 at 9:20 PM">Yesterday at 9:20 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022583" data-xf-init="share-tooltip" data-href="/posts/34022583/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022583" rel="nofollow">
#6
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022583" data-lb-caption-desc="kirengased &middot; Jan 7, 2020 at 9:20 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">Kingreza kinaendana na cha bosiwake!! Bati wayi? Huyo jamaa agome kuwekwa ndani maagizo ya ametakiwa awekwe on sio in</div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022583" data-xf-init="share-tooltip" data-href="/posts/34022583/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022583" rel="nofollow">
#6
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022583" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:20:13+0300" data-time="1578421213" data-date-string="Jan 7, 2020" data-time-string="9:20 PM" title="Jan 7, 2020 at 9:20 PM">Yesterday at 9:20 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li><li><span class="reaction reaction--small reaction--3" data-reaction-id="3"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Haha" title="Haha" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022583/reactions" data-xf-click="overlay" data-cache="false"><bdi>HOPECOMFORT</bdi>, <bdi>sungwa.j</bdi>, <bdi>mahakama ya kazi</bdi> and 30 others</a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<article class="message message--post js-post js-inlineModContainer
  " data-author="popbwinyo" data-content="post-34022587" id="js-post-34022587">
<span class="u-anchorTarget" id="post-34022587"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/popbwinyo.301073/" class="avatar avatar--m" data-user-id="301073" data-xf-init="member-tooltip">
<img src="/data/avatars/m/301/301073.jpg?1466965504" srcset="/data/avatars/l/301/301073.jpg?1466965504 2x" alt="popbwinyo" class="avatar-u301073-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/popbwinyo.301073/" class="username " dir="auto" data-user-id="301073" data-xf-init="member-tooltip" itemprop="name">popbwinyo</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>Jul 11, 2015</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>4,668</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/popbwinyo.301073/" class="avatar avatar--m" data-user-id="301073" data-xf-init="member-tooltip">
<img src="/data/avatars/m/301/301073.jpg?1466965504" srcset="/data/avatars/l/301/301073.jpg?1466965504 2x" alt="popbwinyo" class="avatar-u301073-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/popbwinyo.301073/" class="username " dir="auto" data-user-id="301073" data-xf-init="member-tooltip" itemprop="name">popbwinyo</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>Jul 11, 2015</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>4,668</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022587" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:20:32+0300" data-time="1578421232" data-date-string="Jan 7, 2020" data-time-string="9:20 PM" title="Jan 7, 2020 at 9:20 PM">Yesterday at 9:20 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022587" data-xf-init="share-tooltip" data-href="/posts/34022587/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022587" rel="nofollow">
#7
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022587" data-lb-caption-desc="popbwinyo &middot; Jan 7, 2020 at 9:20 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">Hiyo kofia ngumu kavaa kama kinga ama kaegesha tu
<blockquote class="bbCodeBlock bbCodeBlock--expandable bbCodeBlock--quote">
<div class="bbCodeBlock-title">
<a href="/goto/post?id=34022499" class="bbCodeBlock-sourceJump" data-xf-click="attribution" data-content-selector="#post-34022499">The only said:</a>
</div>
<div class="bbCodeBlock-content">
<div class="bbCodeBlock-expandContent ">
Hapa Akitoa maagizo ya kukamatwa muhandisi mchina
<a href="https://www.jamiiforums.com/attachments/1315270/" target="_blank">View attachment 1315270</a>
<br />
<br />
Sent using <a href="https://r.tapatalk.com/byo?rid=77694" target="_blank" class="link link--external" rel="nofollow noopener">Jamii Forums mobile app</a>
</div>
<div class="bbCodeBlock-expandLink"><a>Click to expand...</a></div>
</div>
</blockquote>Sent using <a href="https://r.tapatalk.com/byo?rid=77694" target="_blank" class="link link--external" rel="nofollow noopener">Jamii Forums mobile app</a></div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022587" data-xf-init="share-tooltip" data-href="/posts/34022587/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022587" rel="nofollow">
#7
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022587" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:20:32+0300" data-time="1578421232" data-date-string="Jan 7, 2020" data-time-string="9:20 PM" title="Jan 7, 2020 at 9:20 PM">Yesterday at 9:20 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022587/reactions" data-xf-click="overlay" data-cache="false"><bdi>sungwa.j</bdi>, <bdi>KISIWAGA</bdi> and <bdi>Ambiele Kiviele</bdi></a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>

<article class="message message--post js-post js-inlineModContainer
  " data-author="Daudi Mchambuzi" data-content="post-34022594" id="js-post-34022594">
<span class="u-anchorTarget" id="post-34022594"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/daudi-mchambuzi.32466/" class="avatar avatar--m" data-user-id="32466" data-xf-init="member-tooltip">
<img src="/data/avatars/m/32/32466.jpg?1472240101" srcset="/data/avatars/l/32/32466.jpg?1472240101 2x" alt="Daudi Mchambuzi" class="avatar-u32466-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/daudi-mchambuzi.32466/" class="username " dir="auto" data-user-id="32466" data-xf-init="member-tooltip" itemprop="name">Daudi Mchambuzi</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>Nov 25, 2010</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>43,611</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/daudi-mchambuzi.32466/" class="avatar avatar--m" data-user-id="32466" data-xf-init="member-tooltip">
<img src="/data/avatars/m/32/32466.jpg?1472240101" srcset="/data/avatars/l/32/32466.jpg?1472240101 2x" alt="Daudi Mchambuzi" class="avatar-u32466-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/daudi-mchambuzi.32466/" class="username " dir="auto" data-user-id="32466" data-xf-init="member-tooltip" itemprop="name">Daudi Mchambuzi</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>Nov 25, 2010</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>43,611</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022594" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:21:28+0300" data-time="1578421288" data-date-string="Jan 7, 2020" data-time-string="9:21 PM" title="Jan 7, 2020 at 9:21 PM">Yesterday at 9:21 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022594" data-xf-init="share-tooltip" data-href="/posts/34022594/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022594" rel="nofollow">
#8
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022594" data-lb-caption-desc="Daudi Mchambuzi &middot; Jan 7, 2020 at 9:21 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">Kingereza cha ki-intaprinyuwaa <br />
<br />
Sent using <a href="https://r.tapatalk.com/byo?rid=77694" target="_blank" class="link link--external" rel="nofollow noopener">Jamii Forums mobile app</a></div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022594" data-xf-init="share-tooltip" data-href="/posts/34022594/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022594" rel="nofollow">
#8
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022594" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:21:28+0300" data-time="1578421288" data-date-string="Jan 7, 2020" data-time-string="9:21 PM" title="Jan 7, 2020 at 9:21 PM">Yesterday at 9:21 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li><li><span class="reaction reaction--small reaction--3" data-reaction-id="3"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Haha" title="Haha" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022594/reactions" data-xf-click="overlay" data-cache="false"><bdi>BADILI TABIA</bdi>, <bdi>sungwa.j</bdi>, <bdi>Erythrocyte</bdi> and 41 others</a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<article class="message message--post js-post js-inlineModContainer
  " data-author="Khan" data-content="post-34022598" id="js-post-34022598">
<span class="u-anchorTarget" id="post-34022598"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/khan.494679/" class="avatar avatar--m" data-user-id="494679" data-xf-init="member-tooltip">
<img src="/data/avatars/m/494/494679.jpg?1566413603" srcset="/data/avatars/l/494/494679.jpg?1566413603 2x" alt="Khan" class="avatar-u494679-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/khan.494679/" class="username " dir="auto" data-user-id="494679" data-xf-init="member-tooltip" itemprop="name">Khan</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>Dec 6, 2012</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>5,987</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/khan.494679/" class="avatar avatar--m" data-user-id="494679" data-xf-init="member-tooltip">
<img src="/data/avatars/m/494/494679.jpg?1566413603" srcset="/data/avatars/l/494/494679.jpg?1566413603 2x" alt="Khan" class="avatar-u494679-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/khan.494679/" class="username " dir="auto" data-user-id="494679" data-xf-init="member-tooltip" itemprop="name">Khan</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>Dec 6, 2012</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>5,987</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022598" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:21:41+0300" data-time="1578421301" data-date-string="Jan 7, 2020" data-time-string="9:21 PM" title="Jan 7, 2020 at 9:21 PM">Yesterday at 9:21 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022598" data-xf-init="share-tooltip" data-href="/posts/34022598/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
 <a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022598" rel="nofollow">
#9
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022598" data-lb-caption-desc="Khan &middot; Jan 7, 2020 at 9:21 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">Wakuu Kiingereza na Uprofessor vina uhusiano gani?<br />
Professor wa Mathematics na Fluent English kuna uhusiano gani?<br />
Almost my whole university life nimefundishwa na Ma Prof. Wengi ambao ni wa mambo ya sayansi.. wote wanaongea kiingereza cha kawaida tu.<br />
<br />
I see no problem there.<br />
<br />
Sent using <a href="https://r.tapatalk.com/byo?rid=77694" target="_blank" class="link link--external" rel="nofollow noopener">Jamii Forums mobile app</a></div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022598" data-xf-init="share-tooltip" data-href="/posts/34022598/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022598" rel="nofollow">
#9
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022598" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:21:41+0300" data-time="1578421301" data-date-string="Jan 7, 2020" data-time-string="9:21 PM" title="Jan 7, 2020 at 9:21 PM">Yesterday at 9:21 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022598/reactions" data-xf-click="overlay" data-cache="false"><bdi>Bf Tulinagwe</bdi>, <bdi>Ibambasi</bdi>, <bdi>sungwa.j</bdi> and 37 others</a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<article class="message message--post js-post js-inlineModContainer
  " data-author="The only" data-content="post-34022600" id="js-post-34022600">
<span class="u-anchorTarget" id="post-34022600"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/the-only.44169/" class="avatar avatar--m" data-user-id="44169" data-xf-init="member-tooltip">
<img src="/data/avatars/m/44/44169.jpg?1499531146" srcset="/data/avatars/l/44/44169.jpg?1499531146 2x" alt="The only" class="avatar-u44169-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/the-only.44169/" class="username " dir="auto" data-user-id="44169" data-xf-init="member-tooltip" itemprop="name">The only</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>May 19, 2011</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>5,078</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/the-only.44169/" class="avatar avatar--m" data-user-id="44169" data-xf-init="member-tooltip">
<img src="/data/avatars/m/44/44169.jpg?1499531146" srcset="/data/avatars/l/44/44169.jpg?1499531146 2x" alt="The only" class="avatar-u44169-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/the-only.44169/" class="username " dir="auto" data-user-id="44169" data-xf-init="member-tooltip" itemprop="name">The only</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>May 19, 2011</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>5,078</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022600" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:21:57+0300" data-time="1578421317" data-date-string="Jan 7, 2020" data-time-string="9:21 PM" title="Jan 7, 2020 at 9:21 PM">Yesterday at 9:21 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022600" data-xf-init="share-tooltip" data-href="/posts/34022600/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022600" rel="nofollow">
#10
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022600" data-lb-caption-desc="The only &middot; Jan 7, 2020 at 9:21 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">Bongo ni kujifanya uko technical
<blockquote class="bbCodeBlock bbCodeBlock--expandable bbCodeBlock--quote">
<div class="bbCodeBlock-title">
<a href="/goto/post?id=34022571" class="bbCodeBlock-sourceJump" data-xf-click="attribution" data-content-selector="#post-34022571">KeyserSoze said:</a>
</div>
<div class="bbCodeBlock-content">
<div class="bbCodeBlock-expandContent ">
Hivi nini kazi ya Helmet
</div>
<div class="bbCodeBlock-expandLink"><a>Click to expand...</a></div>
</div>
</blockquote>Sent using <a href="https://r.tapatalk.com/byo?rid=77694" target="_blank" class="link link--external" rel="nofollow noopener">Jamii Forums mobile app</a></div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022600" data-xf-init="share-tooltip" data-href="/posts/34022600/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022600" rel="nofollow">
#10
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022600" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:21:57+0300" data-time="1578421317" data-date-string="Jan 7, 2020" data-time-string="9:21 PM" title="Jan 7, 2020 at 9:21 PM">Yesterday at 9:21 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022600/reactions" data-xf-click="overlay" data-cache="false"><bdi>sungwa.j</bdi>, <bdi>Sky Eclat</bdi> and <bdi>hazard Don</bdi></a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<div class="samCodeUnit" data-position="post_below_container_10"><div class="samItem"><div class="AdvallyTag" data-autosize="leaderboard" style="margin: 0 auto; text-align: center;"></div></div></div>

<article class="message message--post js-post js-inlineModContainer
  " data-author="Khan" data-content="post-34022607" id="js-post-34022607">
<span class="u-anchorTarget" id="post-34022607"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/khan.494679/" class="avatar avatar--m" data-user-id="494679" data-xf-init="member-tooltip">
<img src="/data/avatars/m/494/494679.jpg?1566413603" srcset="/data/avatars/l/494/494679.jpg?1566413603 2x" alt="Khan" class="avatar-u494679-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/khan.494679/" class="username " dir="auto" data-user-id="494679" data-xf-init="member-tooltip" itemprop="name">Khan</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>Dec 6, 2012</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>5,987</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/khan.494679/" class="avatar avatar--m" data-user-id="494679" data-xf-init="member-tooltip">
<img src="/data/avatars/m/494/494679.jpg?1566413603" srcset="/data/avatars/l/494/494679.jpg?1566413603 2x" alt="Khan" class="avatar-u494679-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/khan.494679/" class="username " dir="auto" data-user-id="494679" data-xf-init="member-tooltip" itemprop="name">Khan</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>Dec 6, 2012</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>5,987</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022607" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:22:30+0300" data-time="1578421350" data-date-string="Jan 7, 2020" data-time-string="9:22 PM" title="Jan 7, 2020 at 9:22 PM">Yesterday at 9:22 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022607" data-xf-init="share-tooltip" data-href="/posts/34022607/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022607" rel="nofollow">
#11
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022607" data-lb-caption-desc="Khan &middot; Jan 7, 2020 at 9:22 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper"><blockquote class="bbCodeBlock bbCodeBlock--expandable bbCodeBlock--quote">
<div class="bbCodeBlock-title">
<a href="/goto/post?id=34022571" class="bbCodeBlock-sourceJump" data-xf-click="attribution" data-content-selector="#post-34022571">KeyserSoze said:</a>
</div>
<div class="bbCodeBlock-content">
<div class="bbCodeBlock-expandContent ">
Hivi nini kazi ya Helmet
</div>
<div class="bbCodeBlock-expandLink"><a>Click to expand...</a></div>
</div>
</blockquote>Safety bro. At site ishu kubwa ni ku minimize Accidents as possible. <br />
<br />
Sent using <a href="https://r.tapatalk.com/byo?rid=77694" target="_blank" class="link link--external" rel="nofollow noopener">Jamii Forums mobile app</a></div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022607" data-xf-init="share-tooltip" data-href="/posts/34022607/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022607" rel="nofollow">
#11
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022607" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:22:30+0300" data-time="1578421350" data-date-string="Jan 7, 2020" data-time-string="9:22 PM" title="Jan 7, 2020 at 9:22 PM">Yesterday at 9:22 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022607/reactions" data-xf-click="overlay" data-cache="false"><bdi>Ibambasi</bdi>, <bdi>sungwa.j</bdi>, <bdi>Honestty</bdi> and 5 others</a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>

</div>
</article>
<article class="message message--post js-post js-inlineModContainer
  " data-author="The only" data-content="post-34022610" id="js-post-34022610">
<span class="u-anchorTarget" id="post-34022610"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/the-only.44169/" class="avatar avatar--m" data-user-id="44169" data-xf-init="member-tooltip">
<img src="/data/avatars/m/44/44169.jpg?1499531146" srcset="/data/avatars/l/44/44169.jpg?1499531146 2x" alt="The only" class="avatar-u44169-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/the-only.44169/" class="username " dir="auto" data-user-id="44169" data-xf-init="member-tooltip" itemprop="name">The only</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>May 19, 2011</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>5,078</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/the-only.44169/" class="avatar avatar--m" data-user-id="44169" data-xf-init="member-tooltip">
<img src="/data/avatars/m/44/44169.jpg?1499531146" srcset="/data/avatars/l/44/44169.jpg?1499531146 2x" alt="The only" class="avatar-u44169-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/the-only.44169/" class="username " dir="auto" data-user-id="44169" data-xf-init="member-tooltip" itemprop="name">The only</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>May 19, 2011</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>5,078</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022610" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:22:40+0300" data-time="1578421360" data-date-string="Jan 7, 2020" data-time-string="9:22 PM" title="Jan 7, 2020 at 9:22 PM">Yesterday at 9:22 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022610" data-xf-init="share-tooltip" data-href="/posts/34022610/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022610" rel="nofollow">
#12
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022610" data-lb-caption-desc="The only &middot; Jan 7, 2020 at 9:22 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">Uwii hahah
<blockquote class="bbCodeBlock bbCodeBlock--expandable bbCodeBlock--quote">
<div class="bbCodeBlock-title">
<a href="/goto/post?id=34022594" class="bbCodeBlock-sourceJump" data-xf-click="attribution" data-content-selector="#post-34022594">Daudi Mchambuzi said:</a>
</div>
<div class="bbCodeBlock-content">
<div class="bbCodeBlock-expandContent ">
Kingereza cha ki-intaprinyuwaa <br />
<br />
Sent using <a href="https://r.tapatalk.com/byo?rid=77694" target="_blank" class="link link--external" rel="nofollow noopener">Jamii Forums mobile app</a>
</div>
<div class="bbCodeBlock-expandLink"><a>Click to expand...</a></div>
</div>
</blockquote>Sent using <a href="https://r.tapatalk.com/byo?rid=77694" target="_blank" class="link link--external" rel="nofollow noopener">Jamii Forums mobile app</a></div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022610" data-xf-init="share-tooltip" data-href="/posts/34022610/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022610" rel="nofollow">
#12
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022610" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:22:40+0300" data-time="1578421360" data-date-string="Jan 7, 2020" data-time-string="9:22 PM" title="Jan 7, 2020 at 9:22 PM">Yesterday at 9:22 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022610/reactions" data-xf-click="overlay" data-cache="false"><bdi>Ubena Zomozi</bdi></a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<article class="message message--post js-post js-inlineModContainer
  " data-author="The only" data-content="post-34022622" id="js-post-34022622">
<span class="u-anchorTarget" id="post-34022622"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/the-only.44169/" class="avatar avatar--m" data-user-id="44169" data-xf-init="member-tooltip">
<img src="/data/avatars/m/44/44169.jpg?1499531146" srcset="/data/avatars/l/44/44169.jpg?1499531146 2x" alt="The only" class="avatar-u44169-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/the-only.44169/" class="username " dir="auto" data-user-id="44169" data-xf-init="member-tooltip" itemprop="name">The only</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>May 19, 2011</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>5,078</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/the-only.44169/" class="avatar avatar--m" data-user-id="44169" data-xf-init="member-tooltip">
<img src="/data/avatars/m/44/44169.jpg?1499531146" srcset="/data/avatars/l/44/44169.jpg?1499531146 2x" alt="The only" class="avatar-u44169-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/the-only.44169/" class="username " dir="auto" data-user-id="44169" data-xf-init="member-tooltip" itemprop="name">The only</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>May 19, 2011</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>5,078</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022622" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:23:21+0300" data-time="1578421401" data-date-string="Jan 7, 2020" data-time-string="9:23 PM" title="Jan 7, 2020 at 9:23 PM">Yesterday at 9:23 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022622" data-xf-init="share-tooltip" data-href="/posts/34022622/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022622" rel="nofollow">
#13
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022622" data-lb-caption-desc="The only &middot; Jan 7, 2020 at 9:23 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">Hiki ni cha kawaida au cha form 2@Khan, <br />
<br />
Sent using <a href="https://r.tapatalk.com/byo?rid=77694" target="_blank" class="link link--external" rel="nofollow noopener">Jamii Forums mobile app</a></div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022622" data-xf-init="share-tooltip" data-href="/posts/34022622/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022622" rel="nofollow">
#13
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022622" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:23:21+0300" data-time="1578421401" data-date-string="Jan 7, 2020" data-time-string="9:23 PM" title="Jan 7, 2020 at 9:23 PM">Yesterday at 9:23 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022622/reactions" data-xf-click="overlay" data-cache="false"><bdi>sungwa.j</bdi>, <bdi>GODZILLA</bdi>, <bdi>Prishaz</bdi> and 9 others</a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<article class="message message--post js-post js-inlineModContainer
  " data-author="eddy" data-content="post-34022629" id="js-post-34022629">
<span class="u-anchorTarget" id="post-34022629"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/eddy.8647/" class="avatar avatar--m avatar--default avatar--default--dynamic" data-user-id="8647" data-xf-init="member-tooltip" style="background-color: #85a3e0; color: #24478f">
<span class="avatar-u8647-m">E</span>
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/eddy.8647/" class="username " dir="auto" data-user-id="8647" data-xf-init="member-tooltip" itemprop="name">eddy</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>Dec 26, 2007</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>12,225</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/eddy.8647/" class="avatar avatar--m avatar--default avatar--default--dynamic" data-user-id="8647" data-xf-init="member-tooltip" style="background-color: #85a3e0; color: #24478f">
<span class="avatar-u8647-m">E</span>
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/eddy.8647/" class="username " dir="auto" data-user-id="8647" data-xf-init="member-tooltip" itemprop="name">eddy</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>Dec 26, 2007</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>12,225</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022629" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:23:54+0300" data-time="1578421434" data-date-string="Jan 7, 2020" data-time-string="9:23 PM" title="Jan 7, 2020 at 9:23 PM">Yesterday at 9:23 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022629" data-xf-init="share-tooltip" data-href="/posts/34022629/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022629" rel="nofollow">
 #14
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022629" data-lb-caption-desc="eddy &middot; Jan 7, 2020 at 9:23 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper"><blockquote class="bbCodeBlock bbCodeBlock--expandable bbCodeBlock--quote">
<div class="bbCodeBlock-title">
<a href="/goto/post?id=34022576" class="bbCodeBlock-sourceJump" data-xf-click="attribution" data-content-selector="#post-34022576">The only said:</a>
</div>
<div class="bbCodeBlock-content">
<div class="bbCodeBlock-expandContent ">
Nimerudia mara kumi cjaelewa huyu si kasoma mpaka PhD kwa kiingereza hiki ni kitu gani?<br />
<br />
Sent using <a href="https://r.tapatalk.com/byo?rid=77694" target="_blank" class="link link--external" rel="nofollow noopener">Jamii Forums mobile app</a>
</div>
<div class="bbCodeBlock-expandLink"><a>Click to expand...</a></div>
</div>
</blockquote>Tena kasoma Canada with first class, Kuna shida mahala, ndo maana hazipendi English medium</div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022629" data-xf-init="share-tooltip" data-href="/posts/34022629/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022629" rel="nofollow">
#14
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022629" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:23:54+0300" data-time="1578421434" data-date-string="Jan 7, 2020" data-time-string="9:23 PM" title="Jan 7, 2020 at 9:23 PM">Yesterday at 9:23 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li><li><span class="reaction reaction--small reaction--3" data-reaction-id="3"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Haha" title="Haha" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022629/reactions" data-xf-click="overlay" data-cache="false"><bdi>sungwa.j</bdi>, <bdi>YEHODAYA</bdi>, <bdi>mahakama ya kazi</bdi> and 24 others</a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<article class="message message--post js-post js-inlineModContainer
  " data-author="Khan" data-content="post-34022642" id="js-post-34022642">
<span class="u-anchorTarget" id="post-34022642"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/khan.494679/" class="avatar avatar--m" data-user-id="494679" data-xf-init="member-tooltip">
<img src="/data/avatars/m/494/494679.jpg?1566413603" srcset="/data/avatars/l/494/494679.jpg?1566413603 2x" alt="Khan" class="avatar-u494679-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/khan.494679/" class="username " dir="auto" data-user-id="494679" data-xf-init="member-tooltip" itemprop="name">Khan</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>Dec 6, 2012</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>5,987</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/khan.494679/" class="avatar avatar--m" data-user-id="494679" data-xf-init="member-tooltip">
<img src="/data/avatars/m/494/494679.jpg?1566413603" srcset="/data/avatars/l/494/494679.jpg?1566413603 2x" alt="Khan" class="avatar-u494679-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/khan.494679/" class="username " dir="auto" data-user-id="494679" data-xf-init="member-tooltip" itemprop="name">Khan</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>Dec 6, 2012</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>5,987</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022642" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:24:54+0300" data-time="1578421494" data-date-string="Jan 7, 2020" data-time-string="9:24 PM" title="Jan 7, 2020 at 9:24 PM">Yesterday at 9:24 PM</time>
</a>
</div>
 <li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022642" data-xf-init="share-tooltip" data-href="/posts/34022642/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022642" rel="nofollow">
#15
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022642" data-lb-caption-desc="Khan &middot; Jan 7, 2020 at 9:24 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper"><blockquote class="bbCodeBlock bbCodeBlock--expandable bbCodeBlock--quote">
<div class="bbCodeBlock-title">
<a href="/goto/post?id=34022622" class="bbCodeBlock-sourceJump" data-xf-click="attribution" data-content-selector="#post-34022622">The only said:</a>
</div>
<div class="bbCodeBlock-content">
<div class="bbCodeBlock-expandContent ">
Hiki ni cha kawaida au cha form 2<br />
<br />
Sent using <a href="https://r.tapatalk.com/byo?rid=77694" target="_blank" class="link link--external" rel="nofollow noopener">Jamii Forums mobile app</a>
</div>
<div class="bbCodeBlock-expandLink"><a>Click to expand...</a></div>
</div>
</blockquote>Ukitaka prof. Aongee terminologies usizozielewa ?</div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022642" data-xf-init="share-tooltip" data-href="/posts/34022642/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022642" rel="nofollow">
#15
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022642" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:24:54+0300" data-time="1578421494" data-date-string="Jan 7, 2020" data-time-string="9:24 PM" title="Jan 7, 2020 at 9:24 PM">Yesterday at 9:24 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022642/reactions" data-xf-click="overlay" data-cache="false"><bdi>sungwa.j</bdi>, <bdi>KISIWAGA</bdi>, <bdi>Mrukus</bdi> and 3 others</a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<div class="samCodeUnit" data-position="post_below_container_15"><div class="samItem"><div class="AdvallyTag" data-autosize="leaderboard" style="margin: 0 auto; text-align: center;"></div></div></div>
<article class="message message--post js-post js-inlineModContainer
  " data-author="kintekunte" data-content="post-34022646" id="js-post-34022646">
<span class="u-anchorTarget" id="post-34022646"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/kintekunte.195485/" class="avatar avatar--m avatar--default avatar--default--dynamic" data-user-id="195485" data-xf-init="member-tooltip" style="background-color: #7a5cd6; color: #eeebfa">
<span class="avatar-u195485-m">K</span>
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/kintekunte.195485/" class="username " dir="auto" data-user-id="195485" data-xf-init="member-tooltip" itemprop="name">kintekunte</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>Jan 5, 2014</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>30</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>125</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/kintekunte.195485/" class="avatar avatar--m avatar--default avatar--default--dynamic" data-user-id="195485" data-xf-init="member-tooltip" style="background-color: #7a5cd6; color: #eeebfa">
<span class="avatar-u195485-m">K</span>
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/kintekunte.195485/" class="username " dir="auto" data-user-id="195485" data-xf-init="member-tooltip" itemprop="name">kintekunte</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>Jan 5, 2014</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>30</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>125</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022646" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:25:22+0300" data-time="1578421522" data-date-string="Jan 7, 2020" data-time-string="9:25 PM" title="Jan 7, 2020 at 9:25 PM">Yesterday at 9:25 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022646" data-xf-init="share-tooltip" data-href="/posts/34022646/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022646" rel="nofollow">
#16
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022646" data-lb-caption-desc="kintekunte &middot; Jan 7, 2020 at 9:25 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">You stay inside</div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022646" data-xf-init="share-tooltip" data-href="/posts/34022646/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022646" rel="nofollow">
#16
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022646" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:25:22+0300" data-time="1578421522" data-date-string="Jan 7, 2020" data-time-string="9:25 PM" title="Jan 7, 2020 at 9:25 PM">Yesterday at 9:25 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li><li><span class="reaction reaction--small reaction--3" data-reaction-id="3"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Haha" title="Haha" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022646/reactions" data-xf-click="overlay" data-cache="false"><bdi>GODZILLA</bdi>, <bdi>Honestty</bdi>, <bdi>Heloo</bdi> and 11 others</a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<article class="message message--post js-post js-inlineModContainer
  " data-author="Mokaze" data-content="post-34022654" id="js-post-34022654">
<span class="u-anchorTarget" id="post-34022654"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/mokaze.498476/" class="avatar avatar--m avatar--default avatar--default--dynamic" data-user-id="498476" data-xf-init="member-tooltip" style="background-color: #f0c2f0; color: #cc33cc">
<span class="avatar-u498476-m">M</span>
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/mokaze.498476/" class="username " dir="auto" data-user-id="498476" data-xf-init="member-tooltip" itemprop="name">Mokaze</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>Aug 3, 2018</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>4,082</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/mokaze.498476/" class="avatar avatar--m avatar--default avatar--default--dynamic" data-user-id="498476" data-xf-init="member-tooltip" style="background-color: #f0c2f0; color: #cc33cc">
<span class="avatar-u498476-m">M</span>
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/mokaze.498476/" class="username " dir="auto" data-user-id="498476" data-xf-init="member-tooltip" itemprop="name">Mokaze</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>Aug 3, 2018</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>4,082</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022654" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:26:11+0300" data-time="1578421571" data-date-string="Jan 7, 2020" data-time-string="9:26 PM" title="Jan 7, 2020 at 9:26 PM">Yesterday at 9:26 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022654" data-xf-init="share-tooltip" data-href="/posts/34022654/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022654" rel="nofollow">
#17
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022654" data-lb-caption-desc="Mokaze &middot; Jan 7, 2020 at 9:26 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper"><blockquote class="bbCodeBlock bbCodeBlock--expandable bbCodeBlock--quote">
<div class="bbCodeBlock-title">
<a href="/goto/post?id=34022499" class="bbCodeBlock-sourceJump" data-xf-click="attribution" data-content-selector="#post-34022499">The only said:</a>
</div>
<div class="bbCodeBlock-content">
<div class="bbCodeBlock-expandContent ">
Hapa Akitoa maagizo ya kukamatwa muhandisi mchina<br />
<a href="https://www.jamiiforums.com/attachments/1315270/" target="_blank">View attachment 1315270</a>
<br />
<br />
Sent using <a href="https://r.tapatalk.com/byo?rid=77694" target="_blank" class="link link--external" rel="nofollow noopener">Jamii Forums mobile app</a>
</div>
<div class="bbCodeBlock-expandLink"><a>Click to expand...</a></div>
</div>
</blockquote><br />
<br />
Mbona kajitahidi sana kuongea kizungu, tatizo ni mifumo yetu ya elimu ni mibovu, watoto tunapokuwa nyumbani ni kiswahili kwa kwenda mbele, tukifika shuleni (sekondari) ni kiswahili kwa kwenda mbele tukiingia darasani ni Kiswanglish (kiswakinge) kwa kwenda mbereee, sasa ni lini tunaweza kuwa good at English??!<img class="smilie smilie--emoji" alt="🤣" title="Rolling on the floor laughing    :rofl:" src="https://cdn.jsdelivr.net/gh/joypixels/emoji-assets@5.0/png/64/1f923.png" data-shortname=":rofl:" /></div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022654" data-xf-init="share-tooltip" data-href="/posts/34022654/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022654" rel="nofollow">
#17
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022654" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:26:11+0300" data-time="1578421571" data-date-string="Jan 7, 2020" data-time-string="9:26 PM" title="Jan 7, 2020 at 9:26 PM">Yesterday at 9:26 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li><li><span class="reaction reaction--small reaction--3" data-reaction-id="3"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Haha" title="Haha" /></span></li><li><span class="reaction reaction--small reaction--4" data-reaction-id="4"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Wow" title="Wow" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022654/reactions" data-xf-click="overlay" data-cache="false"><bdi>Lizarazu</bdi>, <bdi>Honestty</bdi>, <bdi>Yaka</bdi> and 4 others</a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<article class="message message--post js-post js-inlineModContainer
  " data-author="Victoire" data-content="post-34022666" id="js-post-34022666">
<span class="u-anchorTarget" id="post-34022666"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/victoire.11226/" class="avatar avatar--m" data-user-id="11226" data-xf-init="member-tooltip">
<img src="/data/avatars/m/11/11226.jpg?1557923332" srcset="/data/avatars/l/11/11226.jpg?1557923332 2x" alt="Victoire" class="avatar-u11226-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/victoire.11226/" class="username " dir="auto" data-user-id="11226" data-xf-init="member-tooltip" itemprop="name">Victoire</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>Jul 4, 2008</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>15,498</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/victoire.11226/" class="avatar avatar--m" data-user-id="11226" data-xf-init="member-tooltip">
<img src="/data/avatars/m/11/11226.jpg?1557923332" srcset="/data/avatars/l/11/11226.jpg?1557923332 2x" alt="Victoire" class="avatar-u11226-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/victoire.11226/" class="username " dir="auto" data-user-id="11226" data-xf-init="member-tooltip" itemprop="name">Victoire</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>Jul 4, 2008</span>

</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>15,498</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022666" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:26:52+0300" data-time="1578421612" data-date-string="Jan 7, 2020" data-time-string="9:26 PM" title="Jan 7, 2020 at 9:26 PM">Yesterday at 9:26 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022666" data-xf-init="share-tooltip" data-href="/posts/34022666/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022666" rel="nofollow">
#18
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022666" data-lb-caption-desc="Victoire &middot; Jan 7, 2020 at 9:26 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">One hundred and fifty million TZS.Kilikuja na meli. Pale Udsm mwalimu anaongea Kinge akiwa darasani tu. Mkitoka nje ni kiswahili mpaka nyumbani. Mtu Kinge anaongea asilimia 3 ,Kiswahili asilimia 97.</div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022666" data-xf-init="share-tooltip" data-href="/posts/34022666/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022666" rel="nofollow">
#18
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022666" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:26:52+0300" data-time="1578421612" data-date-string="Jan 7, 2020" data-time-string="9:26 PM" title="Jan 7, 2020 at 9:26 PM">Yesterday at 9:26 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li><li><span class="reaction reaction--small reaction--3" data-reaction-id="3"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Haha" title="Haha" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022666/reactions" data-xf-click="overlay" data-cache="false"><bdi>Bf Tulinagwe</bdi>, <bdi>Askof tza</bdi>, <bdi>mahakama ya kazi</bdi> and 14 others</a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<article class="message message--post js-post js-inlineModContainer
  " data-author="KeyserSoze" data-content="post-34022716" id="js-post-34022716">
<span class="u-anchorTarget" id="post-34022716"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/keysersoze.211709/" class="avatar avatar--m" data-user-id="211709" data-xf-init="member-tooltip">
<img src="/data/avatars/m/211/211709.jpg?1394820722" srcset="/data/avatars/l/211/211709.jpg?1394820722 2x" alt="KeyserSoze" class="avatar-u211709-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/keysersoze.211709/" class="username " dir="auto" data-user-id="211709" data-xf-init="member-tooltip" itemprop="name">KeyserSoze</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>Feb 26, 2014</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>2,929</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/keysersoze.211709/" class="avatar avatar--m" data-user-id="211709" data-xf-init="member-tooltip">
<img src="/data/avatars/m/211/211709.jpg?1394820722" srcset="/data/avatars/l/211/211709.jpg?1394820722 2x" alt="KeyserSoze" class="avatar-u211709-m" itemprop="image" />
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/keysersoze.211709/" class="username " dir="auto" data-user-id="211709" data-xf-init="member-tooltip" itemprop="name">KeyserSoze</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>Feb 26, 2014</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>2,929</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022716" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:32:04+0300" data-time="1578421924" data-date-string="Jan 7, 2020" data-time-string="9:32 PM" title="Jan 7, 2020 at 9:32 PM">Yesterday at 9:32 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022716" data-xf-init="share-tooltip" data-href="/posts/34022716/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022716" rel="nofollow">
#19
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022716" data-lb-caption-desc="KeyserSoze &middot; Jan 7, 2020 at 9:32 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper"><blockquote class="bbCodeBlock bbCodeBlock--expandable bbCodeBlock--quote">
<div class="bbCodeBlock-title">
<a href="/goto/post?id=34022607" class="bbCodeBlock-sourceJump" data-xf-click="attribution" data-content-selector="#post-34022607">Khan said:</a>
</div>
<div class="bbCodeBlock-content">
<div class="bbCodeBlock-expandContent ">
Safety bro. At site ishu kubwa ni ku minimize Accidents as possible.<br />
<br />
Sent using <a href="https://r.tapatalk.com/byo?rid=77694" target="_blank" class="link link--external" rel="nofollow noopener">Jamii Forums mobile app</a>
</div>
<div class="bbCodeBlock-expandLink"><a>Click to expand...</a></div>
</div>
</blockquote>safety ya nywele au kichwa ?</div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022716" data-xf-init="share-tooltip" data-href="/posts/34022716/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022716" rel="nofollow">
#19
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022716" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:32:04+0300" data-time="1578421924" data-date-string="Jan 7, 2020" data-time-string="9:32 PM" title="Jan 7, 2020 at 9:32 PM">Yesterday at 9:32 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li><li><span class="reaction reaction--small reaction--3" data-reaction-id="3"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Haha" title="Haha" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022716/reactions" data-xf-click="overlay" data-cache="false"><bdi>Bf Tulinagwe</bdi>, <bdi>Lord eyes</bdi>, <bdi>King Mufasa</bdi> and 3 others</a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<article class="message message--post js-post js-inlineModContainer
  " data-author="Johnny Sack" data-content="post-34022749" id="js-post-34022749">
<span class="u-anchorTarget" id="post-34022749"></span>
<div class="message-inner">
<div class="message-cell message-cell--user hideThreadView">
<section itemscope itemtype="https://schema.org/Person" class="message-user">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/johnny-sack.410952/" class="avatar avatar--m avatar--default avatar--default--dynamic" data-user-id="410952" data-xf-init="member-tooltip" style="background-color: #cc6666; color: #602020">
<span class="avatar-u410952-m">J</span>
</a>
</div>
</div>
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/johnny-sack.410952/" class="username " dir="auto" data-user-id="410952" data-xf-init="member-tooltip" itemprop="name">Johnny Sack</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="message-userExtras">
<dl class="pairs pairs--justified">
<dt>Joined</dt>
<dd>Jan 21, 2017</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Messages</dt>
<dd>1,138</dd>
</dl>
<dl class="pairs pairs--justified">
<dt>Points</dt>
<dd>2,000</dd>
</dl>
</div>
<span class="message-userArrow"></span>
</section>
</div>
<div class="message-cell message-cell--main">
<div class="message-main js-quickEditTarget">
<header class="message-attribution message-attribution--split brvMessageUser">
<div class="message-avatar ">
<div class="message-avatar-wrapper">
<a href="/members/johnny-sack.410952/" class="avatar avatar--m avatar--default avatar--default--dynamic" data-user-id="410952" data-xf-init="member-tooltip" style="background-color: #cc6666; color: #602020">
<span class="avatar-u410952-m">J</span>
</a>
</div>
</div>
<div class="message-info">
<div class="message-userDetails">
<h4 class="message-name"><a href="/members/johnny-sack.410952/" class="username " dir="auto" data-user-id="410952" data-xf-init="member-tooltip" itemprop="name">Johnny Sack</a></h4>
<h5 class="userTitle message-userTitle" dir="auto" itemprop="jobTitle">JF-Expert Member</h5>
</div>
<div class="js-brvLastepostdate show-xxs" style="font-size: 14px;"></div>
<div class="message-joinDate hidden-xxs">
<span>Joined</span>
<span>Jan 21, 2017</span>
</div>
<div class="message-otherDetail hidden-xxs">
<div class="message--userExtras">
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/rep.png"></span>
<span>1,138</span>
</span>
<span class="userExtrasItem">
<span><img src="/styles/brivium/jamii/extra/point.png"></span>
<span>2,000</span>
</span>
</div>
</div>
</div>
<ul class="message-attribution-opposite message-attribution-opposite--list">
<div class="message-attribution-main hidden-xxs">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022749" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:34:47+0300" data-time="1578422087" data-date-string="Jan 7, 2020" data-time-string="9:34 PM" title="Jan 7, 2020 at 9:34 PM">Yesterday at 9:34 PM</time>
</a>
</div>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022749" data-xf-init="share-tooltip" data-href="/posts/34022749/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022749" rel="nofollow">
#20
</a>
</li>
</ul>
</header>
<div class="message-content js-messageContent">
<div class="message-userContent lbContainer js-lbContainer " data-lb-id="post-34022749" data-lb-caption-desc="Johnny Sack &middot; Jan 7, 2020 at 9:34 PM">
<article class="message-body js-selectToQuote">
<div class="bbWrapper">Naona kaongea Kiingereza kinachoeleweka mbona, hautegemei aongee kama mzungu, maana muda mwingi anazungumza Kiswahili</div>
<div class="js-selectToQuoteEnd">&nbsp;</div>
</article>
</div>
</div>
<footer class="message-footer">
<div class="message-actionBar actionBar">
<div class="actionBar-set actionBar-set--external">
<ul class="message-attribution-opposite message-attribution-opposite--list hideThreadView">
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022749" data-xf-init="share-tooltip" data-href="/posts/34022749/share" rel="nofollow">
<i class="fa--xf far fa-share-alt" aria-hidden="true"></i>
</a>
</li>
<li>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022749" rel="nofollow">
#20
</a>
</li>
</ul>
</div>
<div class="actionBar-set actionBar-set--internal">
<div class="message-attribution-main hideThreadView">
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/post-34022749" class="u-concealed" rel="nofollow">
<time class="u-dt" dir="auto" datetime="2020-01-07T21:34:47+0300" data-time="1578422087" data-date-string="Jan 7, 2020" data-time-string="9:34 PM" title="Jan 7, 2020 at 9:34 PM">Yesterday at 9:34 PM</time>
</a>
</div>
</div>
</div>
<div class="reactionsBar js-reactionsList is-active">
<ul class="reactionSummary">
<li><span class="reaction reaction--small reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" /></span></li>
</ul>
<span class="u-srOnly">Reactions:</span>
<a class="reactionsBar-link" href="/posts/34022749/reactions" data-xf-click="overlay" data-cache="false"><bdi>Ibambasi</bdi>, <bdi>August</bdi> and <bdi>Thesis</bdi></a>
</div>
<div class="js-historyTarget message-historyTarget toggleTarget" data-href="trigger-href"></div>
</footer>
</div>
</div>
</div>
</article>
<div class="samCodeUnit" data-position="post_below_container_20"><div class="samItem"><div class="AdvallyTag" data-autosize="leaderboard" style="margin: 0 auto; text-align: center;"></div></div></div>
</div>
</div>
<div class="block-outer block-outer--after">
<div class="block-outer-main"><nav class="pageNavWrapper pageNavWrapper--full ">
<div class="pageNav  pageNav--skipEnd">

<ul class="pageNav-main">
<li class="pageNav-page pageNav-page--current "><a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/">1</a></li>
<li class="pageNav-page pageNav-page--later"><a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-2">2</a></li>
<li class="pageNav-page pageNav-page--later"><a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-3">3</a></li>
<li class="pageNav-page pageNav-page--skip pageNav-page--skipEnd">
<a data-xf-init="tooltip" title="Go to page" data-xf-click="menu" role="button" tabindex="0" aria-expanded="false" aria-haspopup="true">…</a>
<div class="menu menu--pageJump" data-menu="menu" aria-hidden="true">
<div class="menu-content">
<h4 class="menu-header">Go to page</h4>
<div class="menu-row" data-xf-init="page-jump" data-page-url="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-%page%">
<div class="inputGroup inputGroup--numbers">
<div class="inputGroup inputGroup--numbers inputNumber" data-xf-init="number-box"><input type="number" pattern="\d*" class="input input--number js-numberBoxTextInput input input--numberNarrow js-pageJumpPage" value="4" min="1" max="20" step="1" required="required" data-menu-autofocus="true" /></div>
<span class="inputGroup-text"><button type="button" class="js-pageJumpGo button"><span class="button-text">Go</span></button></span>
</div>
</div>
</div>
</div>
</li>
<li class="pageNav-page "><a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-20">20</a></li>
</ul>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-2" class="pageNav-jump pageNav-jump--next">Next</a>
</div>
<div class="pageNavSimple">
<a class="pageNavSimple-el pageNavSimple-el--current" data-xf-init="tooltip" title="Go to page" data-xf-click="menu" role="button" tabindex="0" aria-expanded="false" aria-haspopup="true">
1 of 20
</a>
<div class="menu menu--pageJump" data-menu="menu" aria-hidden="true">
<div class="menu-content">
<h4 class="menu-header">Go to page</h4>
<div class="menu-row" data-xf-init="page-jump" data-page-url="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-%page%">
<div class="inputGroup inputGroup--numbers">
<div class="inputGroup inputGroup--numbers inputNumber" data-xf-init="number-box"><input type="number" pattern="\d*" class="input input--number js-numberBoxTextInput input input--numberNarrow js-pageJumpPage" value="1" min="1" max="20" step="1" required="required" data-menu-autofocus="true" /></div>
<span class="inputGroup-text"><button type="button" class="js-pageJumpGo button"><span class="button-text">Go</span></button></span>
</div>
</div>
</div>
</div>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-2" class="pageNavSimple-el pageNavSimple-el--next">
Next <i aria-hidden="true"></i>
</a>
<a href="/threads/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877/page-20" class="pageNavSimple-el pageNavSimple-el--last" data-xf-init="tooltip" title="Last">
<i aria-hidden="true"></i> <span class="u-srOnly">Last</span>
</a>
</div>
</nav>
</div>
<div class="block-outer-opposite">
<a href="/login/" class="button--link button" data-xf-click="overlay" data-overlay-config="{&quot;className&quot;:&quot;CustomLoginForm&quot;}"><span class="button-text">
You must log in or register to reply here.
 </span></a>
</div>
</div>
</div>
<div class="blockMessage blockMessage--none">
<div class="shareButtons shareButtons--iconic" data-xf-init="share-buttons" data-page-url="" data-page-title="" data-page-desc="">
<span class="shareButtons-label">Share:</span>
<div class="shareButtons-buttons">
<a class="shareButtons-button shareButtons-button--brand shareButtons-button--facebook" data-href="https://www.facebook.com/sharer.php?u={url}">
<i aria-hidden="true"></i>
<span>Facebook</span>
</a>
<a class="shareButtons-button shareButtons-button--brand shareButtons-button--twitter" data-href="https://twitter.com/intent/tweet?url={url}&amp;text={title}&amp;via=JamiiForums">
<i aria-hidden="true"></i>
<span>Twitter</span>
</a>
<a class="shareButtons-button shareButtons-button--brand shareButtons-button--reddit" data-href="https://reddit.com/submit?url={url}&amp;title={title}">
<i aria-hidden="true"></i>
<span>Reddit</span>
</a>
<a class="shareButtons-button shareButtons-button--brand shareButtons-button--whatsApp" data-href="https://api.whatsapp.com/send?text={title}&nbsp;{url}">
<i aria-hidden="true"></i>
<span>WhatsApp</span>
</a>
<a class="shareButtons-button shareButtons-button--email" data-href="mailto:?subject={title}&amp;body={url}">
<i aria-hidden="true"></i>
<span>Email</span>
</a>
<a class="shareButtons-button shareButtons-button--link is-hidden" data-clipboard="{url}">
<i aria-hidden="true"></i>
<span>Link</span>
</a>
</div>
</div>
</div>
<div class="similarthreads-wrapper-wide">
<div class="similarthreads-block">
<div class="block-container">
<div class="block-body">
<div class="dataList ">
<table class="dataList-table">
<tr class="dataList-row dataList-row--header dataList-row--noHover">
<th class="dataList-cell">Thread starter</th>
<th class="dataList-cell">Similar threads</th>
<th class="dataList-cell">Forum</th>
<th class="dataList-cell">Replies</th>
<th class="dataList-cell">Date</th>
</tr>
<tr class="dataList-row dataList-row--noHover">
<td class="dataList-cell">
<span class="contentRow-figure">
<a href="/members/zero-iq.405234/" class="avatar avatar--xs" data-user-id="405234" data-xf-init="member-tooltip">
<img src="/data/avatars/s/405/405234.jpg?1540877605" srcset="/data/avatars/m/405/405234.jpg?1540877605 2x" alt="Zero IQ" class="avatar-u405234-s" />
</a>
</span>
</td>
<td class="dataList-cell dataList-cell--link"><a href="/threads/hivi-mungu-akiamua-kusamehe-kwa-kupitia-kipengele-hiki-ni-kina-nani-wataenda-mbinguni.1623057/"> Hivi Mungu akiamua kusamehe kwa kupitia kipengele hiki ni kina Nani wataenda mbinguni</a></td>
<td class="dataList-cell"><a href="/forums/habari-na-hoja-mchanganyiko.42/">Habari na Hoja mchanganyiko</a></td>
<td class="dataList-cell">30</td>
<td class="dataList-cell"><time class="u-dt" dir="auto" datetime="2019-08-30T13:58:05+0300" data-time="1567162685" data-date-string="Aug 30, 2019" data-time-string="1:58 PM" title="Aug 30, 2019 at 1:58 PM">Aug 30, 2019</time></td>
</tr>
<tr class="dataList-row dataList-row--noHover">
<td class="dataList-cell">
<span class="contentRow-figure">
<a href="/members/francis-da-don.168549/" class="avatar avatar--xs" data-user-id="168549" data-xf-init="member-tooltip">
<img src="/data/avatars/s/168/168549.jpg?1568153488" srcset="/data/avatars/m/168/168549.jpg?1568153488 2x" alt="FRANCIS DA DON" class="avatar-u168549-s" />
</a>
</span>
</td>
<td class="dataList-cell dataList-cell--link"><a href="/threads/hivi-mbona-laki-1-imekosa-thamani-kiasi-hiki-yaani-inakuwa-kama-elfu-10.1611100/"> Hivi mbona laki 1 imekosa thamani kiasi hiki? Yaani inakuwa kama elfu 10?</a></td>
<td class="dataList-cell"><a href="/forums/habari-na-hoja-mchanganyiko.42/">Habari na Hoja mchanganyiko</a></td>
<td class="dataList-cell">96</td>
<td class="dataList-cell"><time class="u-dt" dir="auto" datetime="2019-07-27T15:31:18+0300" data-time="1564230678" data-date-string="Jul 27, 2019" data-time-string="3:31 PM" title="Jul 27, 2019 at 3:31 PM">Jul 27, 2019</time></td>
</tr>
<tr class="dataList-row dataList-row--noHover">
<td class="dataList-cell">
<span class="contentRow-figure">
<a href="/members/franc-the-great.367339/" class="avatar avatar--xs" data-user-id="367339" data-xf-init="member-tooltip">
<img src="/data/avatars/s/367/367339.jpg?1575154575" srcset="/data/avatars/m/367/367339.jpg?1575154575 2x" alt="FRANC THE GREAT" class="avatar-u367339-s" />
</a>
</span>
</td>
<td class="dataList-cell dataList-cell--link"><a href="/threads/baada-ya-hiki-kilichotokea-kule-misri-kuna-jamaa-fulani-hivi-maarufu-lazima-atakuwa-anacheka-kwa-dharau.1600552/"> Baada ya hiki kilichotokea kule Misri, kuna jamaa fulani hivi maarufu, lazima atakuwa &#039;anacheka kwa dharau&#039;</a></td>
<td class="dataList-cell"><a href="/forums/habari-na-hoja-mchanganyiko.42/">Habari na Hoja mchanganyiko</a></td>
<td class="dataList-cell">21</td>
<td class="dataList-cell"><time class="u-dt" dir="auto" datetime="2019-06-28T01:34:22+0300" data-time="1561674862" data-date-string="Jun 28, 2019" data-time-string="1:34 AM" title="Jun 28, 2019 at 1:34 AM">Jun 28, 2019</time></td>
</tr>
<tr class="dataList-row dataList-row--noHover">
<td class="dataList-cell">
<span class="contentRow-figure">
<a href="/members/team-b-13.467412/" class="avatar avatar--xs" data-user-id="467412" data-xf-init="member-tooltip">
<img src="/data/avatars/s/467/467412.jpg?1550919200" srcset="/data/avatars/m/467/467412.jpg?1550919200 2x" alt="TEAM B-13" class="avatar-u467412-s" />
</a>
</span>
</td>
<td class="dataList-cell dataList-cell--link"><a href="/threads/hivi-kitu-gani-hiki-kinacho-niumiza-wakuu-karibuni.1529833/"> Hivi kitu gani hiki kinacho niumiza wakuu karibuni</a></td>
<td class="dataList-cell"><a href="/forums/habari-na-hoja-mchanganyiko.42/">Habari na Hoja mchanganyiko</a></td>
<td class="dataList-cell">4</td>
<td class="dataList-cell"><time class="u-dt" dir="auto" datetime="2018-12-31T23:05:08+0300" data-time="1546286708" data-date-string="Dec 31, 2018" data-time-string="11:05 PM" title="Dec 31, 2018 at 11:05 PM">Dec 31, 2018</time></td>
</tr>
<tr class="dataList-row dataList-row--noHover">
<td class="dataList-cell">
<span class="contentRow-figure">
<a href="/members/yudatade-edesi-shayo.378925/" class="avatar avatar--xs avatar--default avatar--default--dynamic" data-user-id="378925" data-xf-init="member-tooltip" style="background-color: #a34729; color: #e6ac99">
<span class="avatar-u378925-s">Y</span>
</a>
</span>
</td>
<td class="dataList-cell dataList-cell--link"><a href="/threads/hivi-ipo-haja-kweli-ya-fungate-honey-moon-kwa-wanandoa-wa-kizazi-hiki.1489218/"> Hivi ipo haja kweli ya fungate&quot;honey moon&quot;kwa wanandoa wa kizazi hiki??</a></td>
<td class="dataList-cell"><a href="/forums/habari-na-hoja-mchanganyiko.42/">Habari na Hoja mchanganyiko</a></td>
<td class="dataList-cell">6</td>
<td class="dataList-cell"><time class="u-dt" dir="auto" datetime="2018-10-02T13:22:08+0300" data-time="1538475728" data-date-string="Oct 2, 2018" data-time-string="1:22 PM" title="Oct 2, 2018 at 1:22 PM">Oct 2, 2018</time></td>
</tr>
</table>
</div>
</div>
</div>
</div>
</div>
<div class="similarthreads-wrapper-narrow">
<div class="similarthreads-block">
<div class="block-container">
<div class="block-body">
<div class="dataList ">
<table class="dataList-table">
<tr class="dataList-row dataList-row--header dataList-row--noHover">
<th class="dataList-cell">Similar threads</th>
</tr>
<tr class="dataList-row dataList-row--noHover">
<td class="dataList-cell">
<span>
<a href="/threads/hivi-mungu-akiamua-kusamehe-kwa-kupitia-kipengele-hiki-ni-kina-nani-wataenda-mbinguni.1623057/"></a>
</span>
<span>
<a href="/threads/hivi-mungu-akiamua-kusamehe-kwa-kupitia-kipengele-hiki-ni-kina-nani-wataenda-mbinguni.1623057/">Hivi Mungu akiamua kusamehe kwa kupitia kipengele hiki ni kina Nani wataenda mbinguni</a>
</span>
</td>
</tr>
<tr class="dataList-row dataList-row--noHover">
<td class="dataList-cell">
<span>
<a href="/threads/hivi-mbona-laki-1-imekosa-thamani-kiasi-hiki-yaani-inakuwa-kama-elfu-10.1611100/"></a>
</span>
<span>
<a href="/threads/hivi-mbona-laki-1-imekosa-thamani-kiasi-hiki-yaani-inakuwa-kama-elfu-10.1611100/">Hivi mbona laki 1 imekosa thamani kiasi hiki? Yaani inakuwa kama elfu 10?</a>
</span>
</td>
</tr>
<tr class="dataList-row dataList-row--noHover">
<td class="dataList-cell">
<span>
<a href="/threads/baada-ya-hiki-kilichotokea-kule-misri-kuna-jamaa-fulani-hivi-maarufu-lazima-atakuwa-anacheka-kwa-dharau.1600552/"></a>
</span>
<span>
<a href="/threads/baada-ya-hiki-kilichotokea-kule-misri-kuna-jamaa-fulani-hivi-maarufu-lazima-atakuwa-anacheka-kwa-dharau.1600552/">Baada ya hiki kilichotokea kule Misri, kuna jamaa fulani hivi maarufu, lazima atakuwa &#039;anacheka kwa dharau&#039;</a>
</span>
</td>
</tr>
<tr class="dataList-row dataList-row--noHover">
<td class="dataList-cell">
<span>
<a href="/threads/hivi-kitu-gani-hiki-kinacho-niumiza-wakuu-karibuni.1529833/"></a>
</span>
<span>
<a href="/threads/hivi-kitu-gani-hiki-kinacho-niumiza-wakuu-karibuni.1529833/">Hivi kitu gani hiki kinacho niumiza wakuu karibuni</a>
</span>
</td>
</tr>
<tr class="dataList-row dataList-row--noHover">
<td class="dataList-cell">
<span>
<a href="/threads/hivi-ipo-haja-kweli-ya-fungate-honey-moon-kwa-wanandoa-wa-kizazi-hiki.1489218/"></a>
</span>
<span>
<a href="/threads/hivi-ipo-haja-kweli-ya-fungate-honey-moon-kwa-wanandoa-wa-kizazi-hiki.1489218/">Hivi ipo haja kweli ya fungate&quot;honey moon&quot;kwa wanandoa wa kizazi hiki??</a>
</span>
</td>
</tr>
</table>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="p-body-sidebar p-have--sidebar">
<div class="samCodeUnit samAlignCenter" data-position="container_sidebar_above"><div class="samItem"><div class="AdvallyTag" data-slot="/111944822/JamiiForums/JamiiF_Sidebar_M1" id="Adslot_SIDEBAR_1" data-size="300x600,300x250,160x600,250x360" style="margin: 0 auto; text-align: center;"></div></div></div>
<div class="block" data-widget-id="7" data-widget-key="forum_overview_forum_statistics" data-widget-definition="forum_statistics">
<div class="block-container">
<h3 class="block-minorHeader block-forum-static"><a>Forum statistics</a></h3>
<div class="block-body block-row forum-static-content">
<div class="forum-static-item">
<img src="/styles/brivium/jamii/extra/thread.png">
<span class="title">Threads</span>
<span class="number">1,375,990</span>
</div>
<div class="forum-static-item">
<img src="/styles/brivium/jamii/extra/member.png">
<span class="title">Members</span>
<span class="number">524,170</span>
</div>
<div class="forum-static-item">
<img src="/styles/brivium/jamii/extra/post.png">
<span class="title">Posts</span>
<span class="number">33,638,731</span>
</div>
</div>
</div>
</div>
<div class="block" data-widget-id="8" data-widget-key="forum_overview_share_page" data-widget-definition="share_page">
<div class="block-container">
<h3 class="block-minorHeader block-share"><a>FOLLOW US</a></h3>
<div class="block-body block-row">
<div class="shareButtons shareButtons--iconic" data-xf-init="share-buttons">
<a class="shareButtons-button shareButtons-button--brand shareButtons-button--facebook" data-href="https://www.facebook.com/JamiiForums">
<i aria-hidden="true"></i>
<span>Facebook</span>
</a>
<a class="shareButtons-button shareButtons-button--brand shareButtons-button--twitter" data-href="https://twitter.com/JamiiForums">
<i aria-hidden="true"></i>
<span>Twitter</span>
</a>
<a class="shareButtons-button shareButtons-button--brand shareButtons-button--telegram" data-href="https://t.me/JamiiForums">
<i aria-hidden="true"></i>
<span>Telegram</span>
</a>
<a class="shareButtons-button shareButtons-button--brand shareButtons-button--instagram" data-href="https://instagram.com/JamiiForums">
<i aria-hidden="true"></i>
<span>Instagram</span>
</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="brv-breadcrumbs brv-breadcrumbs__bottom">
<div class="brv-breadcrumbs-position">
</div>
<div class="brv-breadcrumbs-inner">
<ul class="p-breadcrumbs p-breadcrumbs--bottom" itemscope itemtype="https://schema.org/BreadcrumbList">
<li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a href="/" itemprop="item">
<span itemprop="name">Forums</span>
</a>
<meta itemprop="position" content="1" />
</li>
<li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a href="/#general-forums.3" itemprop="item">
<span itemprop="name">General Forums</span>
</a>
<meta itemprop="position" content="2" />
</li>
<li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem">
<a href="/forums/habari-na-hoja-mchanganyiko.42/" itemprop="item">
<span itemprop="name">Habari na Hoja mchanganyiko</span>
</a>
<meta itemprop="position" content="3" />
</li>
</ul>
</div>
<div class="brv-breadcrumbs-position">
<div class="samCodeUnit" data-position="container_breadcrumb_bottom_below"><div class="samItem"><div class="AdvallyTag" data-slot="/111944822/JamiiForums/JamiiF_FOOT_LB1" id="Adslot_FOOT_LB1" data-autosize="leaderboard" style="margin: 0 auto; text-align: center;"></div></div></div>
</div>
</div>
<footer class="p-footer" id="footer">
<div class="p-footer-inner">
<div class="samCodeUnit" data-position="footer"><div class="samItem"><script type="text/javascript">_atrk_opts = { atrk_acct:"NI5sk1aklw00w8", domain:"jamiiforums.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();</script><noscript><img src="https://certify.alexametrics.com/atrk.gif?account=NI5sk1aklw00w8" style="display:none" height="1" width="1" alt="" /></noscript></div></div>
<div class="footer-custom">
<div class="row">
<div class="footer-column footer-column-1">
<div class="footer-title"> <h3>Who we are</h3> </div> <div class="content-inner"> <p>JamiiForums is a 'User Generated Content' site; anyone can register (MUST) and comment or start a new topic. <br> You are always welcome!</p> <a href="/misc/contact">Read more...</a> </div>
</div>
<div class="footer-column footer-column-2">
<div class="footer-title"> <h3>Where are we?</h3> </div> <div class="content-inner"> <p>We have our offices in Dar es Salaam but we still work virtually.  <br> For anything related to this site please Contact us.</p> <a href="/misc/contact">Contact us now...</a> </div>
</div>
<div class="footer-column footer-column-3">
<div class="footer-title"> <h3>DISCLAIMER</h3> </div> <div class="content-inner"> <p>JamiiForums, its partners, affiliates and advertisers are not responsible for the content of threads/topics that are submitted by users..</p> <a href="/misc/contact">Read more...</a> </div>
</div>
<div class="footer-column footer-column-4">
<div class="footer-title"> <h3>Forum Rules</h3> </div> <div class="content-inner"> <p>JamiiForums is moderated under the rules set by users and moderators to safeguard you. <br> You MUST read them and comply accordingly.</p> <a href="/help/terms/">Read more...</a> </div>
</div>
<div class="footer-column footer-column-5">
<div class="footer-title"> <h3>Privacy Policy</h3> </div> <div class="content-inner"> <p>We are committed to respecting your privacy rights when visiting any JamiiForums.com page, such as this one. <br> Read our Privacy Policy. </p> <a href="/help/privacy-policy/">Proceed here...</a> </div>
</div>
</div>
</div>
</div>
<div class="footer-bottom">
<div class="p-footer-inner">
<div class="samCodeUnit" data-position="footer"><div class="samItem"><script type="text/javascript">_atrk_opts = { atrk_acct:"NI5sk1aklw00w8", domain:"jamiiforums.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();</script><noscript><img src="https://certify.alexametrics.com/atrk.gif?account=NI5sk1aklw00w8" style="display:none" height="1" width="1" alt="" /></noscript></div></div>
<div class="footerBottomContent">
<div class="footerBottom--left">
</div>
<div class="footerBottom--right">
<ul class="p-footer-linkList">
<li><a href="/misc/contact" data-xf-click="overlay">Contact us</a></li>
<li><a href="/help/terms/">Terms and rules</a></li>
<li><a href="/help/privacy-policy/">JamiiForums' Privacy Policy</a></li>
<li><a href="/help/">Help</a></li>
</ul>
<span class="UptoTop js-scrollTop">Up to top<i class="fa fa-caret-up" aria-hidden="true"></i></span>
</div>
</div>
</div>
</div>
<div class="footer-copyright">
<div class="p-footer-inner">
<div class="samCodeUnit" data-position="footer"><div class="samItem"><script type="text/javascript">_atrk_opts = { atrk_acct:"NI5sk1aklw00w8", domain:"jamiiforums.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();</script><noscript><img src="https://certify.alexametrics.com/atrk.gif?account=NI5sk1aklw00w8" style="display:none" height="1" width="1" alt="" /></noscript></div></div>
<div class="p-footer-copyright">
<div id="BRCopyright" class="concealed muted" style="float:left;margin-left: 10px;"><style>@media (max-width:480px){.Responsive #BRCopyright span{display: none;}}</style><div class="muted"><a href="http://brivium.com/" class="concealed" title="Brivium Limited"><span>XenForo </span>Add-ons by Brivium<span> &trade; &copy; 2012-2020 Brivium LLC.</span></a></div></div>
<div class="BRCopyright" style="display: block;">
<style>@media (max-width:480px){.Responsive #BRCopyright span{display: none;}}</style>
<div class="content-brcpright">
<a href="http://brivium.com/xenforo-add-ons" class="item-brcp" title="Brivium XenForo Add-ons">XenForo Add-ons</a>
<span>&</span>
<a href="http://brivium.com/xenforo-styles" class="item-brcp" title="Brivium XenForo Styles">XenForo Styles</a>
<span> ™ © 2012-2017 Brivium LLC.</span>
</div>
</div>
</div>
</div>
</div>
</footer>
</div> 
<div class="u-bottomFixer js-bottomFixTarget">
<ul class="notices notices--floating  js-notices" data-xf-init="notices" data-type="floating" data-scroll-interval="6">
<li class="notice js-notice notice--primary" data-notice-id="1" data-delay-duration="0" data-display-duration="0" data-auto-dismiss="" data-visibility="">
<div class="notice-content">
<a href="/account/dismiss-notice?notice_id=1" class="notice-dismiss js-noticeDismiss" data-xf-init="tooltip" title="Dismiss notice"></a>
You are browsing this site as a guest. It takes 2 minutes to <a href="https://www.jamiiforums.com/register/"><B>CREATE AN ACCOUNT</B></a> and less than 1 minute to <a href="https://www.jamiiforums.com/login/"><B>LOGIN</B></a>
</div>
</li>
</ul>
</div>
<div class="u-scrollButtons js-scrollButtons" data-trigger-type="up">
<a href="#top" class="button--scroll button" data-xf-click="scroll-to"><span class="button-text"><i class="fa--xf far fa-arrow-up" aria-hidden="true"></i><span class="u-srOnly">Top</span></span></a>
</div>
<script src="/js/vendor/jquery/jquery-3.3.1.min.js?_v=107c3596"></script>
<script src="/js/vendor/vendor-compiled.js?_v=107c3596"></script>
<script src="/js/xf/core-compiled.js?_v=107c3596"></script>
<script>
	XF.samViewCountMethod = "view";
	XF.samServerTime = 1578491137;
</script>
<script src="/js/xf/lightbox-compiled.js?_v=107c3596"></script>
<script src="/js/siropu/am/core.min.js?_v=107c3596"></script>
<script src="/js/xf/notice.min.js?_v=107c3596"></script>
<script src="/js/brivium/jamii/notice.js?_v=107c3596"></script>
<script>jQuery.extend(XF.phrases, {
		brms_category:       "Category",
		brms_download:       "Download",
		brms_update:         "Update",
		brms_review:         "Review",
		brms_rating: "Rating",
		brms_forum:          "Forum",
		brms_views:          "Views",
		brms_replies:        "Replies",
		brms_likes:          "Likes",
});
</script>
<script>
		jQuery.extend(true, XF.config, {
			// 
			userId: 0,
			enablePush: true,
			pushAppServerKey: 'BFGDawLymsO71rfzmaaMJLhnw4IUWo51cykbe1ji2eTYwtnhqN+kCE6LDz9NroMVOLcgKFz/uCWPjBUoNUgnQWI=',
			url: {
				fullBase: 'https://www.jamiiforums.com/',
				basePath: '/',
				css: '/css.php?css=__SENTINEL__&s=10&l=1&d=1578214590',
				keepAlive: '/login/keep-alive'
			},
			cookie: {
				path: '/',
				domain: '',
				prefix: 'xf_',
				secure: true
			},
			csrf: '1578491137,66289f6011e46c53cb52f7e28f66f358',
			js: {"\/js\/xf\/lightbox-compiled.js?_v=107c3596":true,"\/js\/siropu\/am\/core.min.js?_v=107c3596":true,"\/js\/xf\/notice.min.js?_v=107c3596":true,"\/js\/brivium\/jamii\/notice.js?_v=107c3596":true},
			css: {"public:andy_similarthreads.less":true,"public:bb_code.less":true,"public:lightbox.less":true,"public:message.less":true,"public:notices.less":true,"public:share_controls.less":true,"public:siropu_ads_manager_ad.less":true,"public:extra.less":true},
			time: {
				now: 1578491137,
				today: 1578430800,
				todayDow: 3,
				tomorrow: 1578517200,
				yesterday: 1578344400,
				week: 1577912400
			},
			borderSizeFeature: '3px',
			fontAwesomeWeight: 'r',
			enableRtnProtect: true,
			enableFormSubmitSticky: true,
			uploadMaxFilesize: 2147483648,
			allowedVideoExtensions: ["m4v","mov","mp4","mp4v","mpeg","mpg","ogv","webm"],
			shortcodeToEmoji: true,
			visitorCounts: {
				conversations_unread: '0',
				alerts_unread: '0',
				total_unread: '0',
				title_count: true,
				icon_indicator: true
			},
			jsState: {},
			publicMetadataLogoUrl: 'https://www.jamiiforums.com/images/logo.png',
			publicPushBadgeUrl: 'https://www.jamiiforums.com/styles/default/xenforo/bell.png'
		});

		jQuery.extend(XF.phrases, {
			// 
			date_x_at_time_y: "{date} at {time}",
			day_x_at_time_y:  "{day} at {time}",
			yesterday_at_x:   "Yesterday at {time}",
			x_minutes_ago:    "{minutes} minutes ago",
			one_minute_ago:   "1 minute ago",
			a_moment_ago:     "A moment ago",
			today_at_x:       "Today at {time}",
			in_a_moment:      "In a moment",
			in_a_minute:      "In a minute",
			in_x_minutes:     "In {minutes} minutes",
			later_today_at_x: "Later today at {time}",
			tomorrow_at_x:    "Tomorrow at {time}",

			day0: "Sunday",
			day1: "Monday",
			day2: "Tuesday",
			day3: "Wednesday",
			day4: "Thursday",
			day5: "Friday",
			day6: "Saturday",

			dayShort0: "Sun",
			dayShort1: "Mon",
			dayShort2: "Tue",
			dayShort3: "Wed",
			dayShort4: "Thu",
			dayShort5: "Fri",
			dayShort6: "Sat",

			month0: "January",
			month1: "February",
			month2: "March",
			month3: "April",
			month4: "May",
			month5: "June",
			month6: "July",
			month7: "August",
			month8: "September",
			month9: "October",
			month10: "November",
			month11: "December",

			active_user_changed_reload_page: "The active user has changed. Reload the page for the latest version.",
			server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
			oops_we_ran_into_some_problems: "Oops! We ran into some problems.",
			oops_we_ran_into_some_problems_more_details_console: "Oops! We ran into some problems. Please try again later. More error details may be in the browser console.",
			file_too_large_to_upload: "The file is too large to be uploaded.",
			uploaded_file_is_too_large_for_server_to_process: "The uploaded file is too large for the server to process.",
			files_being_uploaded_are_you_sure: "Files are still being uploaded. Are you sure you want to submit this form?",
			attach: "Attach files",
			rich_text_box: "Rich text box",
			close: "Close",
			link_copied_to_clipboard: "Link copied to clipboard.",
			text_copied_to_clipboard: "Text copied to clipboard.",
			loading: "Loading…",

			processing: "Processing",
			'processing...': "Processing…",

			showing_x_of_y_items: "Showing {count} of {total} items",
			showing_all_items: "Showing all items",
			no_items_to_display: "No items to display",

			push_enable_notification_title: "Push notifications enabled successfully at JamiiForums",
			push_enable_notification_body: "Thank you for enabling push notifications!"
		});
	</script>
<form style="display:none" hidden="hidden">
<input type="text" name="_xfClientLoadTime" value="" id="_xfClientLoadTime" title="_xfClientLoadTime" tabindex="-1" />
</form>
<script type="text/template" id="xfReactTooltipTemplate">
		<div class="tooltip-content-inner">
			<div class="reactTooltip">
				
					<a href="#" class="reaction reaction--1" data-reaction-id="1"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Thanks" title="Thanks" data-xf-init="tooltip" /></a>
				
					<a href="#" class="reaction reaction--2" data-reaction-id="2"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Love" title="Love" data-xf-init="tooltip" /></a>
				
					<a href="#" class="reaction reaction--3" data-reaction-id="3"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Haha" title="Haha" data-xf-init="tooltip" /></a>
				
					<a href="#" class="reaction reaction--4" data-reaction-id="4"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Wow" title="Wow" data-xf-init="tooltip" /></a>
				
					<a href="#" class="reaction reaction--5" data-reaction-id="5"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Sad" title="Sad" data-xf-init="tooltip" /></a>
				
					<a href="#" class="reaction reaction--6" data-reaction-id="6"><i aria-hidden="true"></i><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="reaction-sprite js-reaction" alt="Dislike" title="Dislike" data-xf-init="tooltip" /></a>
				
			</div>
		</div>
	</script>
<script src="/js/brivium/jamii/brfunction.js"></script>
<script src="/js/brivium/jamii/slick.min.js"></script>
<script type="application/ld+json">
		{
			"@context": "https://schema.org",
			"@type": "DiscussionForumPosting",
			"@id": "https:\/\/www.jamiiforums.com\/threads\/hivi-hiki-ndicho-kiingereza-cha-profesa-ndalichako.1675877\/",
			"headline": "Hivi hiki ndicho Kiingereza cha Profesa Ndalichako?",
			"articleBody": "Hapa Waziri wa Elimu, Profesa Ndalichako akitoa maagizo ya kukamatwa Mhandisi Mchina.\n\n\nKWA WASIOSIKIA VIZURI AMESEMA\n\n‘’Advance payment ya hi nanii milioni mia moja hamsini  ,your going to stay on the cell until you provide serious explanation on matter ,because now you cannot play with the government like this  ,last time I came here equipment like this ,then you take to another site so your going to stay inside until your give instruction for the equipment you have taken to Dodoma to come back here make sure you have sufficient people to work on the site mheshimiwa sasa kawaweke hawa siwezi kuwa ….’’\n\nCURRICULUM VITAE\n\nEarly life and education[edit]\nShe was born on May 21, 1964, in Musoma, Mara Region in Tanzania. She attended University of Dar Es Salaam from 1987–1991, where she graduated with Bachelor of Science with education, majoring in mathematics. During 1993–1997 she went to University of Alberta, Edmonton, Alberta, Canada, where she obtained a PhD in educational psychology, major in educational statistics & measurement and evaluation.[2]\n\nCareer[edit]\n\nFrom 2000 to 2005 she was the senior lecturer at the University of Dar Es Salaam teaching educational measurement and evaluation, research methods, and educational statistics, supervising dissertation of the students.[3][2]\nFrom 2014 to date she has been the associate professor and deputy head researcher at Agha Khan University Institute for Educational Development, East Africa [2][3]\n\n\n\n\nhttps:\/\/www.jamiiforums.com\/threads\/kiingereza-si-lugha-yetu.1676267\/\n\nSent using Jamii Forums mobile app",
			"articleSection": "Habari na Hoja mchanganyiko",
			"author": {
				"@type": "Person",
				"name": "The only"
			},
			"datePublished": "2020-01-07",
			"dateModified": "2020-01-08",
			"image": "https:\/\/www.jamiiforums.com\/data\/avatars\/l\/44\/44169.jpg?1499531146",
			"interactionStatistic": {
				"@type": "InteractionCounter",
				"interactionType": "https://schema.org/ReplyAction",
				"userInteractionCount": 392
			},
			"publisher": {
				"@type": "Organization",
				"name": "JamiiForums",
				"logo": {
					"@type": "ImageObject",
					"url": "https:\/\/www.jamiiforums.com\/images\/logo.png"
				}
			},
			"mainEntityOfPage": {
				"@type": "WebPage",
				"@id": "https://www.jamiiforums.com"
			}
		}
		</script>
</body>
</html>
