Wadungu nimegota nisaidieni -Configure PHP5 to Work with Apache

MkamaP

JF-Expert Member
Jan 27, 2007
7,972
2,000
nimefuata step zote hizi.Lakini mambo bado magumu.
1.With the Windows Explorer, create the folder c:\webs\test. This will be our test website.

2. Rename the c:\php\php.ini-dist to c:\php\php.ini, then make the following changes in the c:\php\php.ini file: (1) doc_root = "c:\webs\test" and (2) extension_dir = "C:\php\ext". Note that you should use BACKSLASHES in the php.ini file.

3.In the file C:\Program Files\Apache Group\Apache2\conf\httpd.conf, change the DocumentRoot entry to: DocumentRoot "C:/webs/test". Note that you should use FORWARD SLASHES in the http.conf file.

4.Also in the file C:\Program Files\Apache Group\Apache2\conf\httpd.conf, change the Directory entry to: <Directory "C:/webs/test">.Note that you should use FORWARD SLASHES in the http.conf file.

5.Again in the C:\Program Files\Apache Group\Apache2\conf\httpd.conf file, add the following lines: hint: to find this position fast, search for "media types"

6.Lastly, we need to make one last change to this C:\Program Files\Apache Group\Apache2\conf\httpd.conf file. Find the "DirectoryIndex" entry and add "index.php" to the end of the line as shown in this screenshot.

7. In order for the changes to take effect, you need to restart Apache. To do this, click the Apache symbol in the lower right-hand corner of your task bar. In the little menu that pops up there, click Apache 2 and then Restart.

Sasa step hizo juu nimezufuata kwa makini lakini nashindwa hiyo step ya saba ya ku restart maana symbol anayoingelea wala haitokei ,kwa namna nyingine php.index siipati.Sasa basi mwenye uelewa anifahamishe nini nakosa ama kuna kitu inabidi niongeze ktk faili ama la php ama la Apache.
Shukrani kwa kunivumilia.
 

MkamaP

JF-Expert Member
Jan 27, 2007
7,972
2,000
Kwanza jaribu ku-turn off IIS, computer system nyingine hazikubali ku-run web server zaidi ya moja na IIS ndiyo default ya microsoft windows OS. Ikiendelea kugoma Jaribu kufuata link hapo chini ni step by step tutotial.
http://minitutorials.com/apache/apache_222_2.shtml

IIS nimeitafuta kule kwenye administrator tool(service) lakini siioni kitu hapo nielekeze kidogo.

Pia ktk pitapita kunasehemu weshauri hiyo option yako ya pili niiongeze kwenye
httfd conf file ktk "LoadModule php"sasa nashindwa niiongeze sehemu gani inamaana naweza iweka sehemu yoyote ile? ama kuna sehemu maalumu.?

Mkubwa nashukuru kwa mchango wako.Na wengine pia wote
 

JuaKali

JF-Expert Member
Nov 14, 2007
778
195
Kama bado inakutatiza kuna Installer package yenye kila kitu, Apache, php and MySql. Hakuna configuration zaidi ni ku-click itainstall kila kitu, ndani ya muda mfupi webserver itakuwa inarun.
www.en.wampserver.com/download.php

Goodluck!
 

ThinkPad

JF-Expert Member
Apr 11, 2008
1,850
1,250
nimefuata step zote hizi.Lakini mambo bado magumu.
1.With the Windows Explorer, create the folder c:\webs\test. This will be our test website.

2. Rename the c:\php\php.ini-dist to c:\php\php.ini, then make the following changes in the c:\php\php.ini file: (1) doc_root = "c:\webs\test" and (2) extension_dir = "C:\php\ext". Note that you should use BACKSLASHES in the php.ini file.

3.In the file C:\Program Files\Apache Group\Apache2\conf\httpd.conf, change the DocumentRoot entry to: DocumentRoot "C:/webs/test". Note that you should use FORWARD SLASHES in the http.conf file.

4.Also in the file C:\Program Files\Apache Group\Apache2\conf\httpd.conf, change the Directory entry to: <Directory "C:/webs/test">.Note that you should use FORWARD SLASHES in the http.conf file.

5.Again in the C:\Program Files\Apache Group\Apache2\conf\httpd.conf file, add the following lines: hint: to find this position fast, search for "media types"

6.Lastly, we need to make one last change to this C:\Program Files\Apache Group\Apache2\conf\httpd.conf file. Find the "DirectoryIndex" entry and add "index.php" to the end of the line as shown in this screenshot.

7. In order for the changes to take effect, you need to restart Apache. To do this, click the Apache symbol in the lower right-hand corner of your task bar. In the little menu that pops up there, click Apache 2 and then Restart.

Sasa step hizo juu nimezufuata kwa makini lakini nashindwa hiyo step ya saba ya ku restart maana symbol anayoingelea wala haitokei ,kwa namna nyingine php.index siipati.Sasa basi mwenye uelewa anifahamishe nini nakosa ama kuna kitu inabidi niongeze ktk faili ama la php ama la Apache.
Shukrani kwa kunivumilia.



pole sana sasa wewe usiangaike sana maana nimefikilia naona hiyo syastem yako ina ugumu flani ambao inakuwa ngumu kukusaidia hapa kwenye net wewe download easy PHP simple to use and no configuration needed,its just some few settings.enjoy your time.
 

Hebrew

JF-Expert Member
Jul 3, 2008
545
250
Jaribu ku test apache server yako kwa kufungua web browser (I/E or mozilla) na type http://127.0.0.1/ or http://localhost/ kwenye URL halafu bonyeza Enter. Kama unaona error, naomba uziweke hapa tuzicheki. Una Windows gani (Xp, 2003 server, Vista)?

Vilevile inabidi ukopi file php.ini toka kwenye c:\php\ kwenda C:\WINDOWS\
Bila hivyo PHP itagoma
 

Gembe

JF-Expert Member
Sep 25, 2007
2,503
1,225
Jaribu ku test apache server yako kwa kufungua web browser (I/E or mozilla) na type http://127.0.0.1/ or http://localhost/ kwenye URL halafu bonyeza Enter. Kama unaona error, naomba uziweke hapa tuzicheki. Una Windows gani (Xp, 2003 server, Vista)?

Vilevile inabidi ukopi file php.ini toka kwenye c:\php\ kwenda C:\WINDOWS\
Bila hivyo PHP itagoma


use Wampserver2....Xxamps ..mambo ya ku config .. siyo ishu tena,after all ni rahisi sana,,ila tumia hizo..
 

MkamaP

JF-Expert Member
Jan 27, 2007
7,972
2,000
wakubwa nawashukuruni sana nametumia wampserver 2.Rahisi sana .Nashukuruni tena tuzidi kusaidiana.
 

Toa taarifa ya maudhui yasiyofaa!

Kuna taarifa umeiona humu JamiiForums na haifai kubaki mtandaoni?
Fanya hivi...

Umesahau Password au akaunti yako?

Unapata ugumu kuikumbuka akaunti yako? Unakwama kuanzisha akaunti?
Contact us

Top Bottom